grthtrhthjhtyjytjytkergtrhtrjytjerhrfh4:24 29/09/2026B ©[òûGI|·ã@s„dZdZddlZdZdZGdd„deƒZGdd „d eƒZd d „Zd=d d„Z dd„Z dd„Z dd„Z dd„Z dd„Zdd„Zdd„Zdd„Zdd „Zd!d"„ZGd#d$„d$ƒZejGd%d&„d&eƒƒZejGd'd(„d(eƒƒZGd)d*„d*ƒZGd+d,„d,eeƒZGd-d.„d.eƒZGd/d0„d0eeƒZGd1d2„d2ƒZee_Gd3d4„d4ƒZGd5d6„d6eeƒZGd7d8„d8eƒZ Gd9d:„d:eeƒZ!Gd;d<„d<ƒZ"e"e_dS)>z•A fast, lightweight IPv4/IPv6 manipulation library in Python. This library is used to create/poke/manipulate IPv4 and IPv6 addresses and networks. z1.0éNé é€c@seZdZdZdS)ÚAddressValueErrorz%A Value Error related to the address.N)Ú__name__Ú __module__Ú __qualname__Ú__doc__©r r ú./opt/alt/python37/lib64/python3.7/ipaddress.pyrsrc@seZdZdZdS)ÚNetmaskValueErrorz%A Value Error related to the netmask.N)rrrrr r r r r sr c CsTyt|ƒSttfk r YnXyt|ƒSttfk rBYnXtd|ƒ‚dS)a®Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Address or IPv6Address object. Raises: ValueError: if the *address* passed isn't either a v4 or a v6 address z0%r does not appear to be an IPv4 or IPv6 addressN)Ú IPv4Addressrr Ú IPv6AddressÚ ValueError)Úaddressr r r Ú ip_addresssrTc CsXy t||ƒSttfk r"YnXy t||ƒSttfk rFYnXtd|ƒ‚dS)aÐTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP network. Either IPv4 or IPv6 networks may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Network or IPv6Network object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Or if the network has host bits set. z0%r does not appear to be an IPv4 or IPv6 networkN)Ú IPv4Networkrr Ú IPv6Networkr)rÚstrictr r r Ú ip_network9s  rc CsTyt|ƒSttfk r YnXyt|ƒSttfk rBYnXtd|ƒ‚dS)agTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Interface or IPv6Interface object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Notes: The IPv?Interface classes describe an Address on a particular Network, so they're basically a combination of both the Address and Network classes. z2%r does not appear to be an IPv4 or IPv6 interfaceN)Ú IPv4Interfacerr Ú IPv6Interfacer)rr r r Ú ip_interfaceWsrcCs.y | dd¡Stk r(tdƒ‚YnXdS)a`Represent an address as 4 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv4 IP address. Returns: The integer address packed as 4 bytes in network (big-endian) order. Raises: ValueError: If the integer is negative or too large to be an IPv4 IP address. éÚbigz&Address negative or too large for IPv4N)Úto_bytesÚ OverflowErrorr)rr r r Úv4_int_to_packedzs rcCs.y | dd¡Stk r(tdƒ‚YnXdS)zõRepresent an address as 16 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv6 IP address. Returns: The integer address packed as 16 bytes in network (big-endian) order. érz&Address negative or too large for IPv6N)rrr)rr r r Úv6_int_to_packedŽs  rcCs*t|ƒ d¡}t|ƒdkr&td|ƒ‚|S)zAHelper to split the netmask and raise AddressValueError if neededú/ézOnly one '/' permitted in %r)ÚstrÚsplitÚlenr)rÚaddrr r r Ú_split_optional_netmaskžs  r%ccsRt|ƒ}t|ƒ}}x.|D]&}|j|jdkr<||fV|}|}qW||fVdS)zÏFind a sequence of sorted deduplicated IPv#Address. Args: addresses: a list of IPv#Address objects. Yields: A tuple containing the first and last IP addresses in the sequence. éN)ÚiterÚnextÚ_ip)Ú addressesÚitÚfirstÚlastÚipr r r Ú_find_address_range¦s    r/cCs$|dkr |St|||d@ ¡ƒS)zåCount the number of zero bits on the right hand side. Args: number: an integer. bits: maximum number of bits to count. Returns: The number of zero bits on the right hand side of the number. rr&)ÚminÚ bit_length)ZnumberÚbitsr r r Ú_count_righthand_zero_bitsºs r3ccsæt|tƒrt|tƒstdƒ‚|j|jkr8td||fƒ‚||krHtdƒ‚|jdkrXt}n|jdkrht}ntdƒ‚|j}|j}|j}x^||kràt t ||ƒ||d  ¡dƒ}||||fƒ}|V|d|>7}|d|j kr„Pq„WdS) a¤Summarize a network range given the first and last IP addresses. Example: >>> list(summarize_address_range(IPv4Address('192.0.2.0'), ... IPv4Address('192.0.2.130'))) ... #doctest: +NORMALIZE_WHITESPACE [IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/31'), IPv4Network('192.0.2.130/32')] Args: first: the first IPv4Address or IPv6Address in the range. last: the last IPv4Address or IPv6Address in the range. Returns: An iterator of the summarized IPv(4|6) network objects. Raise: TypeError: If the first and last objects are not IP addresses. If the first and last objects are not the same version. ValueError: If the last object is not greater than the first. If the version of the first address is not 4 or 6. z1first and last must be IP addresses, not networksz%%s and %s are not of the same versionz*last IP address must be greater than firstrézunknown IP versionr&N) Ú isinstanceÚ _BaseAddressÚ TypeErrorÚversionrrrÚ_max_prefixlenr)r0r3r1Ú _ALL_ONES)r,r-r.Zip_bitsZ first_intZlast_intZnbitsÚnetr r r Úsummarize_address_rangeÊs0         r<ccs˜t|ƒ}i}xL|rX| ¡}| ¡}| |¡}|dkr>|||<q||kr||=| |¡qWd}x4t| ¡ƒD]$}|dk r†|j|jkr†ql|V|}qlWdS)auLoops through the addresses, collapsing concurrent netblocks. Example: ip1 = IPv4Network('192.0.2.0/26') ip2 = IPv4Network('192.0.2.64/26') ip3 = IPv4Network('192.0.2.128/26') ip4 = IPv4Network('192.0.2.192/26') _collapse_addresses_internal([ip1, ip2, ip3, ip4]) -> [IPv4Network('192.0.2.0/24')] This shouldn't be called directly; it is called via collapse_addresses([]). Args: addresses: A list of IPv4Network's or IPv6Network's Returns: A list of IPv4Network's or IPv6Network's depending on what we were passed. N)ÚlistÚpopÚsupernetÚgetÚappendÚsortedÚvaluesÚbroadcast_address)r*Zto_mergeÚsubnetsr;r?Zexistingr-r r r Ú_collapse_addresses_internals$   rFc Cs8g}g}g}xä|D]Ü}t|tƒrT|rH|dj|jkrHtd||dfƒ‚| |¡q|j|jkr¼|rˆ|dj|jkrˆtd||dfƒ‚y| |j¡Wqîtk r¸| |j ¡YqîXq|rä|dj|jkrätd||dfƒ‚| |¡qWt t |ƒƒ}|�r,x&t |ƒD]\}}|  t||ƒ¡�qWt||ƒS)aËCollapse a list of IP objects. Example: collapse_addresses([IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/25')]) -> [IPv4Network('192.0.2.0/24')] Args: addresses: An iterator of IPv4Network or IPv6Network objects. Returns: An iterator of the collapsed IPv(4|6)Network objects. Raises: TypeError: If passed a list of mixed version objects. éÿÿÿÿz%%s and %s are not of the same version)r5r6Ú_versionr7rAÚ _prefixlenr9r.ÚAttributeErrorÚnetwork_addressrBÚsetr/Úextendr<rF)r*ZaddrsZipsZnetsr.r,r-r r r Úcollapse_addresses2s4     rNcCs(t|tƒr| ¡St|tƒr$| ¡StS)a2Return a key suitable for sorting between networks and addresses. Address and Network objects are not sortable by default; they're fundamentally different so the expression IPv4Address('192.0.2.0') <= IPv4Network('192.0.2.0/24') doesn't make any sense. There are some times however, where you may wish to have ipaddress sort these for you anyway. If you need to do this, you can use this function as the key= argument to sorted(). Args: obj: either a Network or Address object. Returns: appropriate key. )r5Ú _BaseNetworkÚ_get_networks_keyr6Ú_get_address_keyÚNotImplemented)Úobjr r r Úget_mixed_type_keyhs   rTc@s¤eZdZdZdZedd„ƒZedd„ƒZedd„ƒZed d „ƒZ d d „Z d d„Z e dd„ƒZ e dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZdd„ZdS)Ú_IPAddressBasezThe mother class.r cCs| ¡S)z:Return the longhand version of the IP address as a string.)Ú_explode_shorthand_ip_string)Úselfr r r Úexploded‡sz_IPAddressBase.explodedcCst|ƒS)z;Return the shorthand version of the IP address as a string.)r!)rWr r r Ú compressedŒsz_IPAddressBase.compressedcCs| ¡S)aIThe name of the reverse DNS pointer for the IP address, e.g.: >>> ipaddress.ip_address("127.0.0.1").reverse_pointer '1.0.0.127.in-addr.arpa' >>> ipaddress.ip_address("2001:db8::1").reverse_pointer '1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.b.d.0.1.0.0.2.ip6.arpa' )Ú_reverse_pointer)rWr r r Úreverse_pointer‘s z_IPAddressBase.reverse_pointercCsdt|ƒf}t|ƒ‚dS)Nz%200s has no version specified)ÚtypeÚNotImplementedError)rWÚmsgr r r r8œsz_IPAddressBase.versioncCsF|dkrd}t|||jfƒ‚||jkrBd}t|||j|jfƒ‚dS)Nrz-%d (< 0) is not permitted as an IPv%d addressz2%d (>= 2**%d) is not permitted as an IPv%d address)rrHr:r9)rWrr^r r r Ú_check_int_address¡s  z!_IPAddressBase._check_int_addresscCs.t|ƒ}||kr*d}t|||||jfƒ‚dS)Nz6%r (len %d != %d) is not permitted as an IPv%d address)r#rrH)rWrZ expected_lenZ address_lenr^r r r Ú_check_packed_addressªs z$_IPAddressBase._check_packed_addresscCs|j|j|?AS)z¦Turn the prefix length into a bitwise netmask Args: prefixlen: An integer, the prefix length. Returns: An integer. )r:)ÚclsÚ prefixlenr r r Ú_ip_int_from_prefix±s z"_IPAddressBase._ip_int_from_prefixc Cs\t||jƒ}|j|}||?}d|>d}||krX|jd}| |d¡}d}t||ƒ‚|S)aReturn prefix length from the bitwise netmask. Args: ip_int: An integer, the netmask in expanded bitwise format Returns: An integer, the prefix length. Raises: ValueError: If the input intermingles zeroes & ones r&érz&Netmask pattern %r mixes zeroes & ones)r3r9rr) raÚip_intZtrailing_zeroesrbZ leading_onesZall_onesZbyteslenZdetailsr^r r r Ú_prefix_from_ip_int¾s      z"_IPAddressBase._prefix_from_ip_intcCsd|}t|ƒd‚dS)Nz%r is not a valid netmask)r )raZ netmask_strr^r r r Ú_report_invalid_netmask×sz&_IPAddressBase._report_invalid_netmaskcCshtj |¡s| |¡y t|ƒ}Wntk r@| |¡YnXd|krX|jksdn| |¡|S)a Return prefix length from a numeric string Args: prefixlen_str: The string to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask r)Ú_BaseV4Ú_DECIMAL_DIGITSÚ issupersetrgÚintrr9)raZ prefixlen_strrbr r r Ú_prefix_from_prefix_stringÜs    z)_IPAddressBase._prefix_from_prefix_stringcCs†y| |¡}Wntk r,| |¡YnXy | |¡Stk rLYnX||jN}y | |¡Stk r€| |¡YnXdS)aTurn a netmask/hostmask string into a prefix length Args: ip_str: The netmask/hostmask to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask/hostmask N)Ú_ip_int_from_stringrrgrfrr:)raÚip_strrer r r Ú_prefix_from_ip_stringõs   z%_IPAddressBase._prefix_from_ip_stringcCsHt|ttfƒr||jfSt|tƒs*t|ƒ}t|ƒdkr:|S|d|jfS)zµHelper function to parse address of Network/Interface. Arg: address: Argument of Network/Interface. Returns: (addr, prefix) tuple. r&r)r5Úbytesrkr9Útupler%r#)rarr r r Ú_split_addr_prefixs    z!_IPAddressBase._split_addr_prefixcCs|jt|ƒffS)N)Ú __class__r!)rWr r r Ú __reduce__/sz_IPAddressBase.__reduce__N)rrrrÚ __slots__ÚpropertyrXrYr[r8r_r`Ú classmethodrcrfrgrlrorrrtr r r r rU�s        " rUc@sdeZdZdZdZdd„Zdd„Zdd„Zd d „Zd d „Z d d„Z dd„Z dd„Z dd„Z dd„ZdS)r6z€A generic IP object. This IP class contains the version independent methods which are used by single IP addresses. r cCs|jS)N)r))rWr r r Ú__int__>sz_BaseAddress.__int__cCs2y|j|jko|j|jkStk r,tSXdS)N)r)rHrJrR)rWÚotherr r r Ú__eq__As   z_BaseAddress.__eq__cCsFt|tƒstS|j|jkr*td||fƒ‚|j|jkrB|j|jkSdS)Nz%%s and %s are not of the same versionF)r5r6rRrHr7r))rWryr r r Ú__lt__Hs     z_BaseAddress.__lt__cCs t|tƒstS| t|ƒ|¡S)N)r5rkrRrs)rWryr r r Ú__add__Ts z_BaseAddress.__add__cCs t|tƒstS| t|ƒ|¡S)N)r5rkrRrs)rWryr r r Ú__sub__Ys z_BaseAddress.__sub__cCsd|jjt|ƒfS)Nz%s(%r))rsrr!)rWr r r Ú__repr__^sz_BaseAddress.__repr__cCst| |j¡ƒS)N)r!Ú_string_from_ip_intr))rWr r r Ú__str__asz_BaseAddress.__str__cCsttt|jƒƒƒS)N)ÚhashÚhexrkr))rWr r r Ú__hash__dsz_BaseAddress.__hash__cCs |j|fS)N)rH)rWr r r rQgsz_BaseAddress._get_address_keycCs|j|jffS)N)rsr))rWr r r rtjsz_BaseAddress.__reduce__N)rrrrrurxrzr{r|r}r~r€rƒrQrtr r r r r63s r6c@sdeZdZdZdd„Zdd„Zdd„Zdd „Zd d „Zd d „Z dd„Z dd„Z dd„Z dd„Z dd„Zedd„ƒZedd„ƒZedd„ƒZedd„ƒZed d!„ƒZed"d#„ƒZed$d%„ƒZed&d'„ƒZd(d)„Zd*d+„Zd,d-„ZdHd0d1„ZdId2d3„Zed4d5„ƒZed6d7„ƒZd8d9„Z d:d;„Z!edd?„ƒZ#ed@dA„ƒZ$edBdC„ƒZ%edDdE„ƒZ&edFdG„ƒZ'd/S)JrOz~A generic IP network object. This IP class contains the version independent methods which are used by networks. cCs i|_dS)N)Ú_cache)rWrr r r Ú__init__wsz_BaseNetwork.__init__cCsd|jjt|ƒfS)Nz%s(%r))rsrr!)rWr r r r~zsz_BaseNetwork.__repr__cCsd|j|jfS)Nz%s/%d)rKrb)rWr r r r€}sz_BaseNetwork.__str__ccs<t|jƒ}t|jƒ}x"t|d|ƒD]}| |¡Vq$WdS)zŸGenerate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the network or broadcast addresses. r&N)rkrKrDÚrangeÚ_address_class)rWÚnetworkÚ broadcastÚxr r r Úhosts€s  z_BaseNetwork.hostsccs<t|jƒ}t|jƒ}x"t||dƒD]}| |¡Vq$WdS)Nr&)rkrKrDr†r‡)rWrˆr‰rŠr r r Ú__iter__Œs  z_BaseNetwork.__iter__cCslt|jƒ}t|jƒ}|dkr>|||kr0tdƒ‚| ||¡S|d7}|||krZtdƒ‚| ||¡SdS)Nrzaddress out of ranger&)rkrKrDÚ IndexErrorr‡)rWÚnrˆr‰r r r Ú __getitem__’s    z_BaseNetwork.__getitem__cCs^t|tƒstS|j|jkr*td||fƒ‚|j|jkrB|j|jkS|j|jkrZ|j|jkSdS)Nz%%s and %s are not of the same versionF)r5rOrRrHr7rKÚnetmask)rWryr r r r{Ÿs       z_BaseNetwork.__lt__cCsFy,|j|jko,|j|jko,t|jƒt|jƒkStk r@tSXdS)N)rHrKrkr�rJrR)rWryr r r rz«s   z_BaseNetwork.__eq__cCstt|jƒt|jƒAƒS)N)r�rkrKr�)rWr r r rƒ³sz_BaseNetwork.__hash__cCsL|j|jkrdSt|tƒrdSt|jƒt|jƒkoBt|jƒkSSdS)NF)rHr5rOrkrKr)rD)rWryr r r Ú __contains__¶s   z_BaseNetwork.__contains__cCs(|j|kp&|j|kp&|j|kp&|j|kS)z*Tell if self is partly contained in other.)rKrD)rWryr r r ÚoverlapsÃs   z_BaseNetwork.overlapscCs<|j d¡}|dkr8| t|jƒt|jƒB¡}||jd<|S)NrD)r„r@r‡rkrKÚhostmask)rWrŠr r r rDÊs    z_BaseNetwork.broadcast_addresscCs8|j d¡}|dkr4| t|jƒ|jA¡}||jd<|S)Nr“)r„r@r‡rkr�r:)rWrŠr r r r“Ós   z_BaseNetwork.hostmaskcCsd|j|jfS)Nz%s/%d)rKrI)rWr r r Úwith_prefixlenÛsz_BaseNetwork.with_prefixlencCsd|j|jfS)Nz%s/%s)rKr�)rWr r r Ú with_netmaskßsz_BaseNetwork.with_netmaskcCsd|j|jfS)Nz%s/%s)rKr“)rWr r r Ú with_hostmaskãsz_BaseNetwork.with_hostmaskcCst|jƒt|jƒdS)z&Number of hosts in the current subnet.r&)rkrDrK)rWr r r Ú num_addressesçsz_BaseNetwork.num_addressescCsdt|ƒf}t|ƒ‚dS)Nz%%200s has no associated address class)r\r])rWr^r r r r‡ìsz_BaseNetwork._address_classcCs|jS)N)rI)rWr r r rbôsz_BaseNetwork.prefixlenccs|j|jkstd||fƒ‚t|tƒs2td|ƒ‚| |¡sLtd||fƒ‚||krXdS| d|j|jf¡}|  ¡\}}xb||krÜ||krÜ| |¡rª|V|  ¡\}}q|| |¡rÈ|V|  ¡\}}q|t d|||fƒ‚q|W||krî|Vn"||krþ|Vnt d|||fƒ‚dS)aºRemove an address from a larger block. For example: addr1 = ip_network('192.0.2.0/28') addr2 = ip_network('192.0.2.1/32') list(addr1.address_exclude(addr2)) = [IPv4Network('192.0.2.0/32'), IPv4Network('192.0.2.2/31'), IPv4Network('192.0.2.4/30'), IPv4Network('192.0.2.8/29')] or IPv6: addr1 = ip_network('2001:db8::1/32') addr2 = ip_network('2001:db8::1/128') list(addr1.address_exclude(addr2)) = [ip_network('2001:db8::1/128'), ip_network('2001:db8::2/127'), ip_network('2001:db8::4/126'), ip_network('2001:db8::8/125'), ... ip_network('2001:db8:8000::/33')] Args: other: An IPv4Network or IPv6Network object of the same type. Returns: An iterator of the IPv(4|6)Network objects which is self minus other. Raises: TypeError: If self and other are of differing address versions, or if other is not a network object. ValueError: If other is not completely contained by self. z%%s and %s are not of the same versionz%s is not a network objectz%s not contained in %sNz%s/%sz3Error performing exclusion: s1: %s s2: %s other: %s) rHr7r5rOÚ subnet_ofrrsrKrbrEÚAssertionError)rWryÚs1Ús2r r r Úaddress_excludeøs6$          z_BaseNetwork.address_excludecCs`|j|jkrtd||fƒ‚|j|jkr,dS|j|jkr other eg: IPv4Network('192.0.2.128/25') > IPv4Network('192.0.2.0/25') IPv6Network('2001:db8::2000/124') > IPv6Network('2001:db8::1000/124') Raises: TypeError if the IP versions are different. z"%s and %s are not of the same typerGr&r)rHr7rKr�)rWryr r r Úcompare_networksCs!      z_BaseNetwork.compare_networkscCs|j|j|jfS)zËNetwork-only key function. Returns an object that identifies this address' network and netmask. This function is a suitable "key" argument for sorted() and list.sort(). )rHrKr�)rWr r r rPssz_BaseNetwork._get_networks_keyr&Nc csÖ|j|jkr|VdS|dk rJ||jkr0tdƒ‚|dkr@tdƒ‚||j}|dkrZtdƒ‚|j|}||jkr~td||fƒ‚t|jƒ}t|jƒd}t|jƒd|?}x(t|||ƒD]}| ||f¡}|Vq¶WdS)aÓThe subnets which join to make the current subnet. In the case that self contains only one IP (self._prefixlen == 32 for IPv4 or self._prefixlen == 128 for IPv6), yield an iterator with just ourself. Args: prefixlen_diff: An integer, the amount the prefix length should be increased by. This should not be set if new_prefix is also set. new_prefix: The desired new prefix length. This must be a larger number (smaller prefix) than the existing prefix. This should not be set if prefixlen_diff is also set. Returns: An iterator of IPv(4|6) objects. Raises: ValueError: The prefixlen_diff is too small or too large. OR prefixlen_diff and new_prefix are both set or new_prefix is a smaller number than the current prefix (smaller number means a larger network) Nznew prefix must be longerr&z(cannot set prefixlen_diff and new_prefixrzprefix length diff must be > 0z0prefix length diff %d is invalid for netblock %s) rIr9rrkrKrDr“r†rs) rWÚprefixlen_diffÚ new_prefixÚ new_prefixlenÚstartÚendÚstepZnew_addrZcurrentr r r rE}s,       z_BaseNetwork.subnetscCsˆ|jdkr|S|dk rB||jkr(tdƒ‚|dkr8tdƒ‚|j|}|j|}|dkrftd|j|fƒ‚| t|jƒt|jƒ|>@|f¡S)aËThe supernet containing the current network. Args: prefixlen_diff: An integer, the amount the prefix length of the network should be decreased by. For example, given a /24 network and a prefixlen_diff of 3, a supernet with a /21 netmask is returned. Returns: An IPv4 network object. Raises: ValueError: If self.prefixlen - prefixlen_diff < 0. I.e., you have a negative prefix length. OR If prefixlen_diff and new_prefix are both set or new_prefix is a larger number than the current prefix (larger number means a smaller network) rNznew prefix must be shorterr&z(cannot set prefixlen_diff and new_prefixz;current prefixlen is %d, cannot have a prefixlen_diff of %d)rIrrbrsrkrKr�)rWržrŸr r r r r?²s     z_BaseNetwork.supernetcCs|jjo|jjS)z»Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )rKÚ is_multicastrD)rWr r r r¤Ûs z_BaseNetwork.is_multicastcCsfy8|j|jkr"t|›d|›d�ƒ‚|j|jko8|j|jkStk r`td|›d|›�ƒ‚YnXdS)Nz and z are not of the same versionz*Unable to test subnet containment between )rHr7rKrDrJ)ÚaÚbr r r Ú _is_subnet_ofçs   z_BaseNetwork._is_subnet_ofcCs | ||¡S)z1Return True if this network is a subnet of other.)r§)rWryr r r r˜ósz_BaseNetwork.subnet_ofcCs | ||¡S)z3Return True if this network is a supernet of other.)r§)rWryr r r Ú supernet_of÷sz_BaseNetwork.supernet_ofcCs|jjo|jjS)zµTest if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. )rKÚ is_reservedrD)rWr r r r©ûs z_BaseNetwork.is_reservedcCs|jjo|jjS)z�Test if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. )rKÚ is_link_localrD)rWr r r rªsz_BaseNetwork.is_link_localcCs|jjo|jjS)zÔTest if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )rKÚ is_privaterD)rWr r r r«s z_BaseNetwork.is_privatecCs|j S)z×Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )r«)rWr r r Ú is_globals z_BaseNetwork.is_globalcCs|jjo|jjS)z¨Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. )rKÚis_unspecifiedrD)rWr r r r­)s z_BaseNetwork.is_unspecifiedcCs|jjo|jjS)z±Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. )rKÚ is_loopbackrD)rWr r r r®5s z_BaseNetwork.is_loopback)r&N)r&N)(rrrrr…r~r€r‹rŒr�r{rzrƒr‘r’rvrDr“r”r•r–r—r‡rbrœr�rPrEr?r¤Ú staticmethodr§r˜r¨r©rªr«r¬r­r®r r r r rOnsF           K0 5 )  rOc @s¶eZdZdZdZdZdedZedƒZ eddd d d d d ddh ƒZ eZ iZ dd„Z edd„ƒZedd„ƒZedd„ƒZedd„ƒZdd„Zdd„Zdd„Zed d!„ƒZed"d#„ƒZd$S)%rhzyBase IPv4 object. The following methods are used by IPv4 objects in both single IP addresses and networks. r rr r&Ú 0123456789éÿéþéüéøéðéàéÀrrcCst|ƒS)N)r!)rWr r r rVYsz$_BaseV4._explode_shorthand_ip_stringcCs�||jkr†t|tƒr<|}d|kr.|jksjn| |¡n.y| |¡}Wntk rh| |¡}YnXt|  |¡ƒ}||f|j|<|j|S)aMake a (netmask, prefix_len) tuple from the given argument. Argument can be: - an integer (the prefix length) - a string representing the prefix length (e.g. "24") - a string representing the prefix netmask (e.g. "255.255.255.0") r) Ú_netmask_cacher5rkr9rgrlr ror rc)raÚargrbr�r r r Ú _make_netmask\s   z_BaseV4._make_netmaskc Cs||s tdƒ‚| d¡}t|ƒdkr.td|ƒ‚yt t|j|ƒd¡Stk rv}ztd||fƒd‚Wdd}~XYnXdS)aTurn the given IP string into an integer for comparison. Args: ip_str: A string, the IP ip_str. Returns: The IP ip_str as an integer. Raises: AddressValueError: if ip_str isn't a valid IPv4 Address. zAddress cannot be emptyÚ.rzExpected 4 octets in %rrz%s in %rN)rr"r#rkÚ from_bytesÚmapÚ _parse_octetr)rarnZoctetsÚexcr r r rmvs   z_BaseV4._ip_int_from_stringcCsŠ|s tdƒ‚|j |¡s(d}t||ƒ‚t|ƒdkrDd}t||ƒ‚t|dƒ}|dkrr|ddkrrd }t||ƒ‚|d kr†td |ƒ‚|S) a Convert a decimal octet into an integer. Args: octet_str: A string, the number to parse. Returns: The octet as an integer. Raises: ValueError: if the octet isn't strictly a decimal from [0..255]. zEmpty octet not permittedz#Only decimal digits permitted in %réz$At most 3 characters permitted in %ré érÚ0z3Ambiguous (octal/decimal) value in %r not permittedr±zOctet %d (> 255) not permitted)rrirjr#rk)raZ octet_strr^Z octet_intr r r r¾�s       z_BaseV4._parse_octetcCsd tt| dd¡ƒ¡S)zÒTurns a 32-bit integer into dotted decimal notation. Args: ip_int: An integer, the IP address. Returns: The IP address as a string in dotted decimal notation. r»rr)Újoinr½r!r)rarer r r rµs z_BaseV4._string_from_ip_intcCsÂ| d¡}t|ƒdkr†y$x|D]}t|ƒ|jkrdSqWWntk rNdSXx0t|ƒD]$\}}|dkrZ|||dkrZdSqZWdSy t|ƒ}Wntk r¦dSXd|ko¼|jkSS)zûVerify that the netmask is valid. Args: netmask: A string, either a prefix or dotted decimal netmask. Returns: A boolean, True if the prefix represents a valid IPv4 netmask. r»rFrr&T)r"r#rkÚ_valid_mask_octetsrÚ enumerater9)rWr�ÚmaskrŠÚidxÚyr r r Ú_is_valid_netmaskÂs"     z_BaseV4._is_valid_netmaskcsh| d¡}y‡fdd„tt|ƒDƒ}Wntk r:dSXt|ƒt|ƒkrPdS|d|dkrddSdS)zÙTest if the IP string is a hostmask (rather than a netmask). Args: ip_str: A string, the potential hostmask. Returns: A boolean, True if the IP string is a hostmask. r»csg|]}|ˆjkr|‘qSr )rÅ)Ú.0rŠ)rWr r ú ísz(_BaseV4._is_hostmask..FrrGT)r"r½rkrr#)rWrnr2Úpartsr )rWr Ú _is_hostmaskás z_BaseV4._is_hostmaskcCs&t|ƒ d¡ddd…}d |¡dS)z�Return the reverse DNS pointer name for the IPv4 address. This implements the method described in RFC1035 3.5. r»NrGz .in-addr.arpa)r!r"rÄ)rWZreverse_octetsr r r rZösz_BaseV4._reverse_pointercCs|jS)N)r9)rWr r r Ú max_prefixlenÿsz_BaseV4.max_prefixlencCs|jS)N)rH)rWr r r r8sz_BaseV4.versionN)rrrrrurHÚ IPV4LENGTHr:Ú frozensetrirÅr9r¸rVrwrºrmr¾rrÊrÎrZrvrÏr8r r r r rhBs$    %  rhc@sŒeZdZdZdZdd„Zedd„ƒZedd„ƒZee   ¡d d „ƒƒZ ee   ¡d d „ƒƒZ ed d„ƒZ edd„ƒZedd„ƒZedd„ƒZdS)r z/Represent and manipulate single IPv4 Addresses.)r)Ú __weakref__cCsrt|tƒr| |¡||_dSt|tƒrF| |d¡t |d¡|_dSt|ƒ}d|krbtd|ƒ‚|  |¡|_dS)a± Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv4Address('192.0.2.1') == IPv4Address(3221225985). or, more generally IPv4Address(int(IPv4Address('192.0.2.1'))) == IPv4Address('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. NrrrzUnexpected '/' in %r) r5rkr_r)rpr`r¼r!rrm)rWrÚaddr_strr r r r…s     zIPv4Address.__init__cCs t|jƒS)z*The binary representation of this address.)rr))rWr r r Úpacked1szIPv4Address.packedcCs ||jjkS)z°Test if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within the reserved IPv4 Network range. )Ú _constantsÚ_reserved_network)rWr r r r©6s zIPv4Address.is_reservedcst‡fdd„ˆjjDƒƒS)z¶Test if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv4-special-registry. c3s|]}ˆ|kVqdS)Nr )rËr;)rWr r ú Ksz)IPv4Address.is_private..)ÚanyrÕÚ_private_networks)rWr )rWr r«As zIPv4Address.is_privatecCs||jjko|j S)N)rÕÚ_public_networkr«)rWr r r r¬MszIPv4Address.is_globalcCs ||jjkS)z­Test if the address is reserved for multicast use. Returns: A boolean, True if the address is multicast. See RFC 3171 for details. )rÕÚ_multicast_network)rWr r r r¤Rs zIPv4Address.is_multicastcCs ||jjkS)z¤Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 5735 3. )rÕÚ_unspecified_address)rWr r r r­]s zIPv4Address.is_unspecifiedcCs ||jjkS)z�Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback per RFC 3330. )rÕÚ_loopback_network)rWr r r r®hszIPv4Address.is_loopbackcCs ||jjkS)z’Test if the address is reserved for link-local. Returns: A boolean, True if the address is link-local per RFC 3927. )rÕÚ_linklocal_network)rWr r r rªrszIPv4Address.is_link_localN)rrrrrur…rvrÔr©Ú functoolsÚ lru_cacher«r¬r¤r­r®rªr r r r r s#    r c@sjeZdZdd„Zdd„Zdd„Zdd„Zd d „Zej Z e d d „ƒZ e d d„ƒZ e dd„ƒZ e dd„ƒZdS)rcCsN| |¡\}}t ||¡t||fdd�|_|jj|_|jj|_|jj|_dS)NF)r)rrr r…rrˆr�r“rI)rWrr$rÇr r r r…s    zIPv4Interface.__init__cCsd| |j¡|jjfS)Nz%s/%d)rr)rˆrb)rWr r r r€ˆs zIPv4Interface.__str__cCsBt ||¡}|r|tkr|Sy |j|jkStk r<dSXdS)NF)r rzrRrˆrJ)rWryÚ address_equalr r r rzŒs   zIPv4Interface.__eq__cCsNt ||¡}|tkrtSy|j|jkp4|j|jko4|Stk rHdSXdS)NF)r r{rRrˆrJ)rWryÚ address_lessr r r r{˜s  zIPv4Interface.__lt__cCst|j|jt|jjƒfƒS)N)r�r)rIrkrˆrK)rWr r r rƒ¤szIPv4Interface.__hash__cCs t|jƒS)N)r r))rWr r r r.©szIPv4Interface.ipcCsd| |j¡|jfS)Nz%s/%s)rr)rI)rWr r r r”­s zIPv4Interface.with_prefixlencCsd| |j¡|jfS)Nz%s/%s)rr)r�)rWr r r r•²s zIPv4Interface.with_netmaskcCsd| |j¡|jfS)Nz%s/%s)rr)r“)rWr r r r–·s zIPv4Interface.with_hostmaskN)rrrr…r€rzr{rƒrUrtrvr.r”r•r–r r r r r}s      rc@s2eZdZdZeZddd„Zee  ¡dd„ƒƒZ dS) raeThis class represents and manipulates 32-bit IPv4 network + addresses.. Attributes: [examples for IPv4Network('192.0.2.0/27')] .network_address: IPv4Address('192.0.2.0') .hostmask: IPv4Address('0.0.0.31') .broadcast_address: IPv4Address('192.0.2.32') .netmask: IPv4Address('255.255.255.224') .prefixlen: 27 TcCs”t ||¡| |¡\}}t|ƒ|_| |¡\|_|_t|jƒ}|t|jƒ@|krx|rdt d|ƒ‚nt|t|jƒ@ƒ|_|j|j dkr�|j |_ dS)aInstantiate a new IPv4 network object. Args: address: A string or integer representing the IP [& network]. '192.0.2.0/24' '192.0.2.0/255.255.255.0' '192.0.0.2/0.0.0.255' are all functionally the same in IPv4. Similarly, '192.0.2.1' '192.0.2.1/255.255.255.255' '192.0.2.1/32' are also functionally equivalent. That is to say, failing to provide a subnetmask will create an object with a mask of /32. If the mask (portion after the / in the argument) is given in dotted quad form, it is treated as a netmask if it starts with a non-zero field (e.g. /255.0.0.0 == /8) and as a hostmask if it starts with a zero field (e.g. 0.255.255.255 == /8), with the single exception of an all-zero mask which is treated as a netmask == /0. If no mask is given, a default of /32 is used. Additionally, an integer can be passed, so IPv4Network('192.0.2.1') == IPv4Network(3221225985) or, more generally IPv4Interface(int(IPv4Interface('192.0.2.1'))) == IPv4Interface('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. NetmaskValueError: If the netmask isn't valid for an IPv4 address. ValueError: If strict is True and a network address is not supplied. z%s has host bits setr&N) rOr…rrr rKrºr�rIrkrr9rŒr‹)rWrrr$rÇrÔr r r r…Ìs$   zIPv4Network.__init__cCs&|jtdƒko|jtdƒk o$|j S)z¹Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry. z 100.64.0.0/10)rKrrDr«)rWr r r r¬s zIPv4Network.is_globalN)T) rrrrr r‡r…rvrßràr¬r r r r r½s   4rc@s”eZdZedƒZedƒZedƒZedƒZedƒedƒedƒedƒedƒedƒed ƒed ƒed ƒed ƒed ƒedƒedƒedƒgZedƒZ e dƒZ dS)Ú_IPv4Constantsz169.254.0.0/16z 127.0.0.0/8z 224.0.0.0/4z 100.64.0.0/10z 0.0.0.0/8z 10.0.0.0/8z 172.16.0.0/12z 192.0.0.0/29z192.0.0.170/31z 192.0.2.0/24z192.168.0.0/16z 198.18.0.0/15z198.51.100.0/24z203.0.113.0/24z 240.0.0.0/4z255.255.255.255/32z0.0.0.0N) rrrrrÞrÝrÛrÚrÙrÖr rÜr r r r rãs( rãc@sžeZdZdZdZdZdedZdZe dƒZ eZ iZ e dd „ƒZe d d „ƒZe d d „ƒZe dd„ƒZe ddd„ƒZdd„Zdd„Zedd„ƒZedd„ƒZdS)Ú_BaseV6zyBase IPv6 object. The following methods are used by IPv6 objects in both single IP addresses and networks. r r4r r&rdZ0123456789ABCDEFabcdefcCsl||jkrbt|tƒr<|}d|kr.|jksFn| |¡n | |¡}t| |¡ƒ}||f|j|<|j|S)aMake a (netmask, prefix_len) tuple from the given argument. Argument can be: - an integer (the prefix length) - a string representing the prefix length (e.g. "24") - a string representing the prefix netmask (e.g. "255.255.255.0") r)r¸r5rkr9rgrlr rc)rar¹rbr�r r r rºEs    z_BaseV6._make_netmaskc Csæ|s tdƒ‚| d¡}d}t|ƒ|kr:d||f}t|ƒ‚d|dkr¶yt| ¡ƒj}Wn4tk rŒ}ztd||fƒd‚Wdd}~XYnX| d |d ?d @¡| d |d @¡|jd }t|ƒ|kräd |d |f}t|ƒ‚d}x@td t|ƒd ƒD]*} || sü|dk �r"d|}t|ƒ‚| }qüW|dk �rÌ|} t|ƒ|d } |d�sp| d 8} | �rpd}t||ƒ‚|d�s˜| d 8} | �r˜d}t||ƒ‚|j| | } | d k�r6d}t||jd |fƒ‚njt|ƒ|jk�ròd}t||j|fƒ‚|d�s d}t||ƒ‚|d�s&d}t||ƒ‚t|ƒ} d} d} ytd} x,t| ƒD] } | d K} | |  || ¡O} �qFW| d | K} x0t| dƒD] } | d K} | |  || ¡O} �q„W| St k �rà}ztd||fƒd‚Wdd}~XYnXdS)zùTurn an IPv6 ip_str into an integer. Args: ip_str: A string, the IPv6 ip_str. Returns: An int, the IPv6 address Raises: AddressValueError: if ip_str isn't a valid IPv6 Address. zAddress cannot be emptyú:rÀz At least %d parts expected in %rr»rGz%s in %rNz%xriÿÿr&z!At most %d colons permitted in %rz At most one '::' permitted in %rrz0Leading ':' only permitted as part of '::' in %rz1Trailing ':' only permitted as part of '::' in %rz/Expected at most %d other parts with '::' in %rz,Exactly %d parts expected without '::' in %r) rr"r#r r>r)rAÚ _HEXTET_COUNTr†Ú _parse_hextetr)rarnrÍZ _min_partsr^Zipv4_intr¿Z _max_partsZ skip_indexÚiZparts_hiZparts_loZ parts_skippedrer r r rmYs„    $              z_BaseV6._ip_int_from_stringcCs>|j |¡std|ƒ‚t|ƒdkr4d}t||ƒ‚t|dƒS)a&Convert an IPv6 hextet string into an integer. Args: hextet_str: A string, the number to parse. Returns: The hextet as an integer. Raises: ValueError: if the input isn't strictly a hex number from [0..FFFF]. zOnly hex digits permitted in %rrz$At most 4 characters permitted in %rr)Ú _HEX_DIGITSrjrr#rk)raZ hextet_strr^r r r rçÁs     z_BaseV6._parse_hextetc Cs¦d}d}d}d}xJt|ƒD]>\}}|dkrP|d7}|dkr>|}||krX|}|}qd}d}qW|dkr¢||}|t|ƒkr‚|dg7}dg|||…<|dkr¢dg|}|S)aäCompresses a list of hextets. Compresses a list of strings, replacing the longest continuous sequence of "0" in the list with "" and adding empty strings at the beginning or at the end of the string such that subsequently calling ":".join(hextets) will produce the compressed version of the IPv6 address. Args: hextets: A list of strings, the hextets to compress. Returns: A list of strings. rGrrÃr&Ú)rÆr#) raÚhextetsZbest_doublecolon_startZbest_doublecolon_lenZdoublecolon_startZdoublecolon_lenÚindexZhextetZbest_doublecolon_endr r r Ú_compress_hextetsÛs.   z_BaseV6._compress_hextetsNcsZ|dkrt|jƒ}||jkr$tdƒ‚d|‰‡fdd„tdddƒDƒ}| |¡}d  |¡S) a,Turns a 128-bit integer into hexadecimal notation. Args: ip_int: An integer, the IP address. Returns: A string, the hexadecimal representation of the address. Raises: ValueError: The address is bigger than 128 bits of all ones. NzIPv6 address is too largez%032xcs&g|]}dtˆ||d…dƒ‘qS)z%xrr)rk)rËrŠ)Úhex_strr r rÌ sz/_BaseV6._string_from_ip_int..rrrrå)rkr)r:rr†rírÄ)rarerër )rîr r s   z_BaseV6._string_from_ip_intcsŒt|tƒrt|jƒ}nt|tƒr,t|jƒ}nt|ƒ}| |¡}d|‰‡fdd„tdddƒDƒ}t|ttfƒr‚dd  |¡|j fSd  |¡S) z¬Expand a shortened IPv6 address. Args: ip_str: A string, the IPv6 address. Returns: A string, the expanded IPv6 address. z%032xcsg|]}ˆ||d…‘qS)rr )rËrŠ)rîr r rÌ8sz8_BaseV6._explode_shorthand_ip_string..rrrz%s/%drå) r5rr!rKrr.rmr†rOrÄrI)rWrnrerÍr )rîr rV%s     z$_BaseV6._explode_shorthand_ip_stringcCs&|jddd… dd¡}d |¡dS)z�Return the reverse DNS pointer name for the IPv6 address. This implements the method described in RFC3596 2.5. NrGrårêr»z .ip6.arpa)rXÚreplacerÄ)rWZ reverse_charsr r r rZ=sz_BaseV6._reverse_pointercCs|jS)N)r9)rWr r r rÏFsz_BaseV6.max_prefixlencCs|jS)N)rH)rWr r r r8Jsz_BaseV6.version)N)rrrrrurHÚ IPV6LENGTHr:rærÑrér9r¸rwrºrmrçrírrVrZrvrÏr8r r r r rä1s$   h  0  räc@s´eZdZdZdZdd„Zedd„ƒZedd„ƒZed d „ƒZ ed d „ƒZ ed d„ƒZ ee   ¡dd„ƒƒZedd„ƒZedd„ƒZedd„ƒZedd„ƒZedd„ƒZedd„ƒZdS)r z/Represent and manipulate single IPv6 Addresses.)r)rÒcCsrt|tƒr| |¡||_dSt|tƒrF| |d¡t |d¡|_dSt|ƒ}d|krbtd|ƒ‚|  |¡|_dS)aInstantiate a new IPv6 address object. Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv6Address('2001:db8::') == IPv6Address(42540766411282592856903984951653826560) or, more generally IPv6Address(int(IPv6Address('2001:db8::'))) == IPv6Address('2001:db8::') Raises: AddressValueError: If address isn't a valid IPv6 address. NrrrzUnexpected '/' in %r) r5rkr_r)rpr`r¼r!rrm)rWrrÓr r r r…Us     zIPv6Address.__init__cCs t|jƒS)z*The binary representation of this address.)rr))rWr r r rÔyszIPv6Address.packedcCs ||jjkS)z»Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )rÕrÛ)rWr r r r¤~s zIPv6Address.is_multicastcst‡fdd„ˆjjDƒƒS)zµTest if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. c3s|]}ˆ|kVqdS)Nr )rËrŠ)rWr r r×’sz*IPv6Address.is_reserved..)rØrÕÚ_reserved_networks)rWr )rWr r©‰s zIPv6Address.is_reservedcCs ||jjkS)z�Test if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. )rÕrÞ)rWr r r rª”szIPv6Address.is_link_localcCs ||jjkS)a`Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )rÕÚ_sitelocal_network)rWr r r Ú is_site_localžs zIPv6Address.is_site_localcst‡fdd„ˆjjDƒƒS)z¶Test if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv6-special-registry. c3s|]}ˆ|kVqdS)Nr )rËr;)rWr r r×¶sz)IPv6Address.is_private..)rØrÕrÙ)rWr )rWr r«¬s zIPv6Address.is_privatecCs|j S)z¹Test if this address is allocated for public networks. Returns: A boolean, true if the address is not reserved per iana-ipv6-special-registry. )r«)rWr r r r¬¸s zIPv6Address.is_globalcCs |jdkS)z¨Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. r)r))rWr r r r­Ãs zIPv6Address.is_unspecifiedcCs |jdkS)z±Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. r&)r))rWr r r r®Îs zIPv6Address.is_loopbackcCs |jd?dkrdSt|jd@ƒS)z¶Return the IPv4 mapped address. Returns: If the IPv6 address is a v4 mapped address, return the IPv4 mapped address. Return None otherwise. riÿÿNlÿÿ)r)r )rWr r r Ú ipv4_mappedÙs zIPv6Address.ipv4_mappedcCs4|jd?dkrdSt|jd?d@ƒt|jd@ƒfS)zÛTuple of embedded teredo IPs. Returns: Tuple of the (server, client) IPs or None if the address doesn't appear to be a teredo address (doesn't start with 2001::/32) é`i Né@lÿÿ)r)r )rWr r r Úteredoæs zIPv6Address.teredocCs$|jd?dkrdSt|jd?d@ƒS)zÎReturn the IPv4 6to4 embedded address. Returns: The IPv4 6to4-embedded address if present or None if the address doesn't appear to contain a 6to4 embedded address. épi NéPlÿÿ)r)r )rWr r r Ú sixtofourõs zIPv6Address.sixtofourN)rrrrrur…rvrÔr¤r©rªrórßràr«r¬r­r®rôr÷rúr r r r r Os $   r c@s‚eZdZdd„Zdd„Zdd„Zdd„Zd d „Zej Z e d d „ƒZ e d d„ƒZ e dd„ƒZ e dd„ƒZe dd„ƒZe dd„ƒZdS)rcCsN| |¡\}}t ||¡t||fdd�|_|jj|_|jj|_|jj|_dS)NF)r)rrr r…rrˆr�r“rI)rWrr$rÇr r r r…s    zIPv6Interface.__init__cCsd| |j¡|jjfS)Nz%s/%d)rr)rˆrb)rWr r r r€s zIPv6Interface.__str__cCsBt ||¡}|r|tkr|Sy |j|jkStk r<dSXdS)NF)r rzrRrˆrJ)rWryrár r r rzs   zIPv6Interface.__eq__cCsNt ||¡}|tkrtSy|j|jkp4|j|jko4|Stk rHdSXdS)NF)r r{rRrˆrJ)rWryrâr r r r{s  zIPv6Interface.__lt__cCst|j|jt|jjƒfƒS)N)r�r)rIrkrˆrK)rWr r r rƒ*szIPv6Interface.__hash__cCs t|jƒS)N)r r))rWr r r r./szIPv6Interface.ipcCsd| |j¡|jfS)Nz%s/%s)rr)rI)rWr r r r”3s zIPv6Interface.with_prefixlencCsd| |j¡|jfS)Nz%s/%s)rr)r�)rWr r r r•8s zIPv6Interface.with_netmaskcCsd| |j¡|jfS)Nz%s/%s)rr)r“)rWr r r r–=s zIPv6Interface.with_hostmaskcCs|jdko|jjS)Nr)r)rˆr­)rWr r r r­BszIPv6Interface.is_unspecifiedcCs|jdko|jjS)Nr&)r)rˆr®)rWr r r r®FszIPv6Interface.is_loopbackN)rrrr…r€rzr{rƒrUrtrvr.r”r•r–r­r®r r r r rs        rc@s2eZdZdZeZd dd„Zdd„Zedd„ƒZ d S) ravThis class represents and manipulates 128-bit IPv6 networks. Attributes: [examples for IPv6('2001:db8::1000/124')] .network_address: IPv6Address('2001:db8::1000') .hostmask: IPv6Address('::f') .broadcast_address: IPv6Address('2001:db8::100f') .netmask: IPv6Address('ffff:ffff:ffff:ffff:ffff:ffff:ffff:fff0') .prefixlen: 124 TcCs”t ||¡| |¡\}}t|ƒ|_| |¡\|_|_t|jƒ}|t|jƒ@|krx|rdt d|ƒ‚nt|t|jƒ@ƒ|_|j|j dkr�|j |_ dS)aæInstantiate a new IPv6 Network object. Args: address: A string or integer representing the IPv6 network or the IP and prefix/netmask. '2001:db8::/128' '2001:db8:0000:0000:0000:0000:0000:0000/128' '2001:db8::' are all functionally the same in IPv6. That is to say, failing to provide a subnetmask will create an object with a mask of /128. Additionally, an integer can be passed, so IPv6Network('2001:db8::') == IPv6Network(42540766411282592856903984951653826560) or, more generally IPv6Network(int(IPv6Network('2001:db8::'))) == IPv6Network('2001:db8::') strict: A boolean. If true, ensure that we have been passed A true network address, eg, 2001:db8::1000/124 and not an IP address on a network, eg, 2001:db8::1/124. Raises: AddressValueError: If address isn't a valid IPv6 address. NetmaskValueError: If the netmask isn't valid for an IPv6 address. ValueError: If strict was True and a network address was not supplied. z%s has host bits setr&N) rOr…rrr rKrºr�rIrkrr9rŒr‹)rWrrr$rÇrÔr r r r…[s   zIPv6Network.__init__ccs@t|jƒ}t|jƒ}x&t|d|dƒD]}| |¡Vq(WdS)z¢Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the Subnet-Router anycast address. r&N)rkrKrDr†r‡)rWrˆr‰rŠr r r r‹Šs  zIPv6Network.hostscCs|jjo|jjS)a`Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )rKrórD)rWr r r ró–s zIPv6Network.is_site_localN)T) rrrrr r‡r…r‹rvrór r r r rKs   / rc@sÂeZdZedƒZedƒZedƒedƒedƒedƒedƒedƒed ƒed ƒed ƒedƒg Zed ƒed ƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒgZedƒZdS)Ú_IPv6Constantsz fe80::/10zff00::/8z::1/128z::/128z ::ffff:0:0/96z100::/64z 2001::/23z 2001:2::/48z 2001:db8::/32z 2001:10::/28zfc00::/7z::/8z100::/8z200::/7z400::/6z800::/5z1000::/4z4000::/3z6000::/3z8000::/3zA000::/3zC000::/3zE000::/4zF000::/5zF800::/6zFE00::/9z fec0::/10N) rrrrrÞrÛrÙrñròr r r r rû¦s*         rû)T)#rÚ __version__rßrÐrðrrr rrrrrr%r/r3r<rFrNrTrUÚtotal_orderingr6rOrhr rrrãrÕrär rrrûr r r r Ú sV #7163:VGu@R 5H[!