grthtrhthjhtyjytjytkergtrhtrjytjerhrfh4:24 29/09/2026B .gæ RœŒã@sldZddlZddlZddlZyddlZdZWnek rDdZYnXddgZGdd„deƒZ dZ d Z d Z d Z e e Zd ZGd d„dƒZer¦Gdd„deƒZe d¡edk�rhddlZeejdƒZee ¡ƒe ejd¡e ejd¡e ¡e ¡\ZZxXededƒD]FZ e !e ¡\Z"Z#Z$ede ƒxe#D]Z%ede%ƒ�qd5d6„Z#d7d8„Z$d9d:„Z%d?d;d<„Z&dS)@raPThis class supports both the minimal and optional command sets. Arguments can be strings or integers (where appropriate) (e.g.: retr(1) and retr('1') both work equally well. Minimal Command Set: USER name user(name) PASS string pass_(string) STAT stat() LIST [msg] list(msg = None) RETR msg retr(msg) DELE msg dele(msg) NOOP noop() RSET rset() QUIT quit() Optional Commands (some servers support these): RPOP name rpop(name) APOP name digest apop(name, digest) TOP msg n top(msg, n) UIDL [msg] uidl(msg = None) CAPA capa() STLS stls() UTF8 utf8() Raises one exception: 'error_proto'. Instantiate with: POP3(hostname, port=110) NB: the POP protocol locks the mailbox from user authorization until QUIT, so be sure to get in, suck the messages, and quit, each time you access the mailbox. POP is a line-based protocol, which means large mail messages consume lots of python cycles reading them line-by-line. If it's available on your mail server, use IMAP4 instead, it doesn't suffer from the two problems above. zUTF-8cCs@||_||_d|_| |¡|_|j d¡|_d|_| ¡|_ dS)NFÚrbr) ÚhostÚportÚ_tls_establishedÚ_create_socketÚsockÚmakefileÚfileÚ _debuggingÚ_getrespÚwelcome)Úselfr rÚtimeoutrrrÚ__init__as z POP3.__init__cCst |j|jf|¡S)N)ÚsocketZcreate_connectionr r)rrrrrrkszPOP3._create_socketcCs,|jdkrtdt|ƒƒ|j |t¡dS)Néz*put*)rÚprintÚreprrZsendallÚCRLF)rÚlinerrrÚ_putlinens z POP3._putlinecCs.|jrtdt|ƒƒt||jƒ}| |¡dS)Nz*cmd*)rrrÚbytesÚencodingr )rrrrrÚ_putcmdus z POP3._putcmdcCs |j td¡}t|ƒtkr$tdƒ‚|jdkr)cCs\t||jƒ}|j |j¡}|s&tdƒ‚ddl}| d¡|}| |¡  ¡}|  d||f¡S)a Authorisation - only possible if server has supplied a timestamp in initial greeting. Args: user - mailbox user; password - mailbox password. NB: mailbox is locked by server from here to 'quit()' z!-ERR APOP not supported by serverrNrz APOP %s %s) r!r"Ú timestampÚmatchrrÚhashlibÚgroupZmd5Z hexdigestr4)rr9ZpasswordZsecretÚmrMZdigestrrrÚapop9s z POP3.apopcCs| d||f¡S)z­Retrieve message header of message number 'which' and first 'howmuch' lines of message body. Result is in form ['response', ['line', ...], octets]. z TOP %s %s)r5)rr?ZhowmuchrrrÚtopNszPOP3.topcCs |dk r| d|¡S| d¡S)zìReturn message digest (unique id) list. If 'which', result contains unique id for that message in the form 'response mesgnum uid', otherwise result is the list ['response', ['mesgnum uid', ...], octets] NzUIDL %sZUIDL)r4r5)rr?rrrÚuidlWsz POP3.uidlcCs | d¡S)zITry to enter UTF-8 mode (see RFC 6856). Returns server response. ZUTF8)r4)rrrrÚutf8csz POP3.utf8c Cstdd„}i}y8| d¡}|d}x |D]}||ƒ\}}|||<q&WWn*tk rn}z tdƒ‚Wdd}~XYnX|S)aReturn server capabilities (RFC 2449) as a dictionary >>> c=poplib.POP3('localhost') >>> c.capa() {'IMPLEMENTATION': ['Cyrus', 'POP3', 'server', 'v2.2.12'], 'TOP': [], 'LOGIN-DELAY': ['0'], 'AUTH-RESP-CODE': [], 'EXPIRE': ['NEVER'], 'USER': [], 'STLS': [], 'PIPELINING': [], 'UIDL': [], 'RESP-CODES': []} >>> Really, according to RFC 2449, the cyrus folks should avoid having the implementation split into multiple arguments... cSs"| d¡ ¡}|d|dd…fS)NÚasciirr)Údecoder<)rZlstrrrÚ _parsecapvszPOP3.capa.._parsecapZCAPArz!-ERR CAPA not supported by serverN)r5r) rrVÚcapsr.ZrawcapsZcaplineZcapnmZcapargsZ_errrrrÚcapais    z POP3.capacCsxts tdƒ‚|jrtdƒ‚| ¡}d|kr2tdƒ‚|dkrBt ¡}| d¡}|j|j|j d�|_|j  d¡|_ d|_|S) z{Start a TLS session on the active connection as specified in RFC 2595. context - a ssl.SSLContext z-ERR TLS support missingz$-ERR TLS session already establishedZSTLSz!-ERR STLS not supported by serverN)Úserver_hostnamer T) ÚHAVE_SSLrrrXÚsslÚ_create_stdlib_contextr4Ú wrap_socketrr rr)rÚcontextrWr.rrrÚstls†s  z POP3.stls)N)N)N)'rrrÚ__doc__r"Ú POP3_PORTrÚ_GLOBAL_DEFAULT_TIMEOUTrrr r#r+rr3r4r5r6r8r9r:r>r2r@rArBrCrErDrJÚreÚcompilerKrPrQrRrSrXr_rrrrr2s@+       c@s8eZdZdZeddejdfdd„Zdd„Zd dd„Z dS) ÚPOP3_SSLaPOP3 client class over SSL connection Instantiate with: POP3_SSL(hostname, port=995, keyfile=None, certfile=None, context=None) hostname - the hostname of the pop3 over ssl server port - port number keyfile - PEM formatted file that contains your private key certfile - PEM formatted certificate chain file context - a ssl.SSLContext See the methods of the parent class POP3 for more documentation. NcCs’|dk r|dk rtdƒ‚|dk r0|dk r0tdƒ‚|dk s@|dk rVddl}| dtd¡||_||_|dkrxtj||d�}||_t   ||||¡dS)Nz4context and keyfile arguments are mutually exclusivez5context and certfile arguments are mutually exclusiverzAkeyfile and certfile are deprecated, use a custom context insteadr;)ÚcertfileÚkeyfile) Ú ValueErrorÚwarningsÚwarnÚDeprecationWarningrgrfr[r\r^rr)rr rrgrfrr^rirrrr­szPOP3_SSL.__init__cCs"t ||¡}|jj||jd�}|S)N)rY)rrr^r]r )rrrrrrrÁs  zPOP3_SSL._create_socketcCs tdƒ‚dS)z¬The method unconditionally raises an exception since the STLS command doesn't make any sense on an already established SSL/TLS session. z$-ERR TLS session already establishedN)r)rrgrfr^rrrr_Çsz POP3_SSL.stls)NNN) rrrr`Ú POP3_SSL_PORTrrbrrr_rrrrrežs  reÚ__main__rr;éz Message %d:z z-----------------------)'r`rGrcrr[rZÚ ImportErrorÚ__all__Ú Exceptionrrarlr)ZLFrr'rrer1rÚsysÚargvÚarr6r9r:r2r>ZnumMsgsZ totalSizeÚrangeÚir@ÚheaderÚmsgr*rrErrrrÚsJ  l0