grthtrhthjhtyjytjytkergtrhtrjytjerhrfh4:24 29/09/2026§ P&Ÿ4¾žÊãó¢—dZdZddlZdZdZGd„de¦«ZGd„d e¦«Zd „Zd3d „Z d „Z d„Z d„Z d„Z d„Zd„Zd„Zd„Zd„Zd„ZGd„d¦«ZdaejGd„de¦«¦«ZejGd„de¦«¦«ZGd„d¦«Zee_Gd„d ¦«ZGd!„d"ee¦«ZGd#„d$e¦«ZGd%„d&ee¦«ZGd'„d(¦«Zee_ee_Gd)„d*¦«Z Gd+„d,e e¦«Z!Gd-„d.e!¦«Z"Gd/„d0e e¦«Z#Gd1„d2¦«Z$e$e!_e$e#_dS)4z•A fast, lightweight IPv4/IPv6 manipulation library in Python. This library is used to create/poke/manipulate IPv4 and IPv6 addresses and networks. z1.0éNé é€có—eZdZdZdS)ÚAddressValueErrorz%A Value Error related to the address.N©Ú__name__Ú __module__Ú __qualname__Ú__doc__©óú0/opt/alt/python311/lib64/python3.11/ipaddress.pyrró€€€€€Ø/Ð/Ð/Ð/r rcó—eZdZdZdS)ÚNetmaskValueErrorz%A Value Error related to the netmask.Nrr r rrrrr rcó— t|¦«S#ttf$rYnwxYw t|¦«S#ttf$rYnwxYwt |›d�¦«‚)a®Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Address or IPv6Address object. Raises: ValueError: if the *address* passed isn't either a v4 or a v6 address z. does not appear to be an IPv4 or IPv6 address)Ú IPv4AddressrrÚ IPv6AddressÚ ValueError©Úaddresss rÚ ip_addressrs�€ð  ݘ7Ñ#Ô#Ð#øÝ Õ0Ð 1ð ð ð Ø ˆð øøøð ݘ7Ñ#Ô#Ð#øÝ Õ0Ð 1ð ð ð Ø ˆð øøøõ ˜ÐQÐQÐQÑ RÔ RÐRó‚‘%¤%©8¸A Á A TcóÆ— t||¦«S#ttf$rYnwxYw t||¦«S#ttf$rYnwxYwt |›d�¦«‚)aÐTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP network. Either IPv4 or IPv6 networks may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Network or IPv6Network object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Or if the network has host bits set. z. does not appear to be an IPv4 or IPv6 network)Ú IPv4NetworkrrÚ IPv6Networkr)rÚstricts rÚ ip_networkr9s‘€ð  ݘ7 FÑ+Ô+Ð+øÝ Õ0Ð 1ð ð ð Ø ˆð øøøð ݘ7 FÑ+Ô+Ð+øÝ Õ0Ð 1ð ð ð Ø ˆð øøøõ ˜ÐQÐQÐQÑ RÔ RÐRs‚’&¥&ª:ºAÁ Acó— t|¦«S#ttf$rYnwxYw t|¦«S#ttf$rYnwxYwt |›d�¦«‚)agTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Interface or IPv6Interface object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Notes: The IPv?Interface classes describe an Address on a particular Network, so they're basically a combination of both the Address and Network classes. z0 does not appear to be an IPv4 or IPv6 interface)Ú IPv4InterfacerrÚ IPv6Interfacerrs rÚ ip_interfacer"Vs�€ð* ݘWÑ%Ô%Ð%øÝ Õ0Ð 1ð ð ð Ø ˆð øøøð ݘWÑ%Ô%Ð%øÝ Õ0Ð 1ð ð ð Ø ˆð øøøõ ˜ÐSÐSÐSÑ TÔ TÐTrcóh— | d¦«S#t$rtd¦«‚wxYw)a`Represent an address as 4 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv4 IP address. Returns: The integer address packed as 4 bytes in network (big-endian) order. Raises: ValueError: If the integer is negative or too large to be an IPv4 IP address. éz&Address negative or too large for IPv4©Úto_bytesÚ OverflowErrorrrs rÚv4_int_to_packedr(xsJ€ðCØ×Ò Ñ"Ô"Ð"øÝ ðCðCðCÝÐAÑBÔBÐBðCøøøó‚—1cóh— | d¦«S#t$rtd¦«‚wxYw)zõRepresent an address as 16 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv6 IP address. Returns: The integer address packed as 16 bytes in network (big-endian) order. éz&Address negative or too large for IPv6r%rs rÚv6_int_to_packedr,ŒsJ€ðCØ×Ò Ñ#Ô#Ð#øÝ ðCðCðCÝÐAÑBÔBÐBðCøøør)có”—t|¦« d¦«}t|¦«dkrtd|›�¦«‚|S)zAHelper to split the netmask and raise AddressValueError if neededú/ézOnly one '/' permitted in )ÚstrÚsplitÚlenr)rÚaddrs rÚ_split_optional_netmaskr4œsF€å ˆw‰<Œ<× Ò ˜cÑ "Ô "€DÝ ˆ4�y„y�1‚}€}ÝÐ H¸WÐ HÐ HÑIÔIÐIØ €Kr c#óšK—t|¦«}t|¦«x}}|D]}|j|jdzkr||fV—|}|}Œ ||fV—dS)zÏFind a sequence of sorted deduplicated IPv#Address. Args: addresses: a list of IPv#Address objects. Yields: A tuple containing the first and last IP addresses in the sequence. éN)ÚiterÚnextÚ_ip)Ú addressesÚitÚfirstÚlastÚips rÚ_find_address_ranger?¤swèè€õ ˆi‰Œ€Bݘ‘8”8ЀEˆDØððˆØ Œ6�T”X ‘\Ò !Ð !ؘ�+РРР؈E؈ˆØ �ˆ+ÐÐÐÐÐr cód—|dkr|St|||dz z ¦«¦«S)zåCount the number of zero bits on the right hand side. Args: number: an integer. bits: maximum number of bits to count. Returns: The number of zero bits on the right hand side of the number. rr6)ÚminÚ bit_length)ÚnumberÚbitss rÚ_count_righthand_zero_bitsrE¸s9€ð�‚{€{؈ Ý ˆt�v�g ¨¡Ñ*×6Ò6Ñ8Ô8Ñ 9Ô 9Ð9r c#ójK—t|t¦«rt|t¦«std¦«‚|j|jkrt|›d|›d�¦«‚||krt d¦«‚|jdkrt }n"|jdkrt }nt d¦«‚|j}|j}|j}||krmtt||¦«||z dz  ¦«dz ¦«}||||z f¦«}|V—|d|zz }|dz |j krd S||k°kd Sd S) a¤Summarize a network range given the first and last IP addresses. Example: >>> list(summarize_address_range(IPv4Address('192.0.2.0'), ... IPv4Address('192.0.2.130'))) ... #doctest: +NORMALIZE_WHITESPACE [IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/31'), IPv4Network('192.0.2.130/32')] Args: first: the first IPv4Address or IPv6Address in the range. last: the last IPv4Address or IPv6Address in the range. Returns: An iterator of the summarized IPv(4|6) network objects. Raise: TypeError: If the first and last objects are not IP addresses. If the first and last objects are not the same version. ValueError: If the last object is not greater than the first. If the version of the first address is not 4 or 6. z1first and last must be IP addresses, not networksú and ú are not of the same versionz*last IP address must be greater than firstr$ézunknown IP versionr6N) Ú isinstanceÚ _BaseAddressÚ TypeErrorÚversionrrrÚ_max_prefixlenr9rArErBÚ _ALL_ONES)r<r=r>Úip_bitsÚ first_intÚlast_intÚnbitsÚnets rÚsummarize_address_rangerUÈszèè€õ4˜�|Ñ ,Ô ,ðMÝ ˜�lÑ +Ô +ðMåÐKÑLÔLÐLØ „}˜œ Ò$Ð$ÝØ˜˜   ð&ñ'ô'ð 'à ˆt‚|€|ÝÐEÑFÔFÐFà „}˜ÒÐÝ ˆˆØ Œ˜!Ò Ð Ý ˆˆåÐ-Ñ.Ô.Ð.àÔ"€GØ” €IØŒx€HØ �xÒ Ð ÝÕ.¨y¸'ÑBÔBØ  Ñ)¨AÑ-×9Ò9Ñ;Ô;¸aÑ?ñAôAˆàˆb�)˜W u™_Ð-Ñ.Ô.ˆØˆ ˆ ˆ Ø�Q˜%‘Zш Ø �q‰=˜BœLÒ (Ð (Ø ˆEð �xÒ Ð Ð Ð Ð Ð r c#óxK—t|¦«}i}|re| ¦«}| ¦«}| |¦«}|€|||<n||kr||=| |¦«|°ed}t | ¦«¦«D]}|�|j|jkrŒ|V—|}ŒdS)auLoops through the addresses, collapsing concurrent netblocks. Example: ip1 = IPv4Network('192.0.2.0/26') ip2 = IPv4Network('192.0.2.64/26') ip3 = IPv4Network('192.0.2.128/26') ip4 = IPv4Network('192.0.2.192/26') _collapse_addresses_internal([ip1, ip2, ip3, ip4]) -> [IPv4Network('192.0.2.0/24')] This shouldn't be called directly; it is called via collapse_addresses([]). Args: addresses: A list of IPv4Network's or IPv6Network's Returns: A list of IPv4Network's or IPv6Network's depending on what we were passed. N)ÚlistÚpopÚsupernetÚgetÚappendÚsortedÚvaluesÚbroadcast_address)r:Úto_mergeÚsubnetsrTrYÚexistingr=s rÚ_collapse_addresses_internalrbÿséèè€õ2�I‰Œ€HØ€GØ ð &Ø�lŠl‰nŒnˆØ—<’<‘>”>ˆØ—;’;˜xÑ(Ô(ˆØ Ð Ø #ˆG�HÑ Ð Ø ˜Š_ˆ_à˜Ð!Ø �OŠO˜HÑ %Ô %Ð %ð ð &ð €DÝ�g—n’nÑ&Ô&Ñ'Ô'ððˆØ Ð ðÔ%¨Ô)>Ò>Ð>ØØˆ ˆ ˆ ؈ˆððr cóJ—g}g}g}|D�]2}t|t¦«rI|r1|dj|jkrt|›d|d›d�¦«‚| |¦«Œa|j|jkry|r1|dj|jkrt|›d|d›d�¦«‚ | |j¦«ŒÀ#t$r| |j ¦«YŒæwxYw|r1|dj|jkrt|›d|d›d�¦«‚| |¦«�Œ4tt|¦«¦«}|r8t|¦«D](\}}|  t||¦«¦«Œ)t||z¦«S)aËCollapse a list of IP objects. Example: collapse_addresses([IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/25')]) -> [IPv4Network('192.0.2.0/24')] Args: addresses: An iterable of IPv4Network or IPv6Network objects. Returns: An iterator of the collapsed IPv(4|6)Network objects. Raises: TypeError: If passed a list of mixed version objects. éÿÿÿÿrGrH)rJrKÚ_versionrLr[Ú _prefixlenrNr>ÚAttributeErrorÚnetwork_addressr\Úsetr?ÚextendrUrb)r:ÚaddrsÚipsÚnetsr>r<r=s rÚcollapse_addressesrn0sñ€ð$ €EØ €CØ €DððñˆÝ �b�,Ñ 'Ô 'ð Øð /�s˜2”wÔ'¨2¬;Ò6Ð6ÝØ!#   S¨¤W W Wð!.ñ/ô/ð/à �JŠJ�r‰NŒNˆNˆNØ Œ]˜bÔ/Ò /Ð /Øð /�s˜2”wÔ'¨2¬;Ò6Ð6ÝØ!#   S¨¤W W Wð!.ñ/ô/ð/ð /Ø— ’ ˜2œ5Ñ!Ô!Ð!Ð!øÝ!ð /ð /ð /Ø— ’ ˜2Ô-Ñ.Ô.Ð.Ð.Ð.ð /øøøðð 0˜˜RœÔ)¨R¬[Ò8Ð8ÝØ!#   T¨"¤X X Xð!/ñ0ô0ð0à �KŠK˜‰OŒOˆO‰Oõ •�S‘”Ñ Ô €Cð ð?Ý.¨sÑ3Ô3ð ?ð ?‰KˆE�4Ø �LŠLÕ0°¸Ñ=Ô=Ñ >Ô >Ð >Ð >å '¨°© Ñ 5Ô 5Ð5sÂ.C à $C0Ã/C0có´—t|t¦«r| ¦«St|t¦«r| ¦«St S)a2Return a key suitable for sorting between networks and addresses. Address and Network objects are not sortable by default; they're fundamentally different so the expression IPv4Address('192.0.2.0') <= IPv4Network('192.0.2.0/24') doesn't make any sense. There are some times however, where you may wish to have ipaddress sort these for you anyway. If you need to do this, you can use this function as the key= argument to sorted(). Args: obj: either a Network or Address object. Returns: appropriate key. )rJÚ _BaseNetworkÚ_get_networks_keyrKÚ_get_address_keyÚNotImplemented)Úobjs rÚget_mixed_type_keyrufsR€õ$�#•|Ñ$Ô$ð&Ø×$Ò$Ñ&Ô&Ð&Ý �C�Ñ &Ô &ð&Ø×#Ò#Ñ%Ô%Ð%Ý Ðr có—eZdZdZdZed„¦«Zed„¦«Zed„¦«Zed„¦«Z d„Z d„Z e d „¦«Z e d „¦«Ze d „¦«Ze d „¦«Ze d „¦«Ze d„¦«Zd„ZdS)Ú_IPAddressBasezThe mother class.r có*—| ¦«S)z:Return the longhand version of the IP address as a string.)Ú_explode_shorthand_ip_string©Úselfs rÚexplodedz_IPAddressBase.exploded…s€ð×0Ò0Ñ2Ô2Ð2r có —t|¦«S)z;Return the shorthand version of the IP address as a string.©r0rzs rÚ compressedz_IPAddressBase.compressedŠs€õ�4‰yŒyÐr có*—| ¦«S)aIThe name of the reverse DNS pointer for the IP address, e.g.: >>> ipaddress.ip_address("127.0.0.1").reverse_pointer '1.0.0.127.in-addr.arpa' >>> ipaddress.ip_address("2001:db8::1").reverse_pointer '1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.b.d.0.1.0.0.2.ip6.arpa' )Ú_reverse_pointerrzs rÚreverse_pointerz_IPAddressBase.reverse_pointer�s€ð×$Ò$Ñ&Ô&Ð&r cóF—dt|¦«fz}t|¦«‚)Nz%200s has no version specified©ÚtypeÚNotImplementedError©r{Úmsgs rrMz_IPAddressBase.versionšs"€à.µ$°t±*´*°Ñ>ˆÝ! #Ñ&Ô&Ð&r có —|dkrd}t|||jfz¦«‚||jkr!d}t|||j|jfz¦«‚dS)Nrz-%d (< 0) is not permitted as an IPv%d addressz2%d (>= 2**%d) is not permitted as an IPv%d address)rrerOrN)r{rrˆs rÚ_check_int_addressz!_IPAddressBase._check_int_addressŸsn€Ø �QŠ;ˆ;ØAˆCÝ# C¨7°D´MÐ*BÑ$BÑCÔCÐ CØ �T”^Ò #Ð #ØFˆCÝ# C¨7°DÔ4GØ+/¬=ð+:ñ%:ñ;ô;ð ;ð $Ð #r cój—t|¦«}||krd}t|||||jfz¦«‚dS)Nz6%r (len %d != %d) is not permitted as an IPv%d address)r2rre)r{rÚ expected_lenÚ address_lenrˆs rÚ_check_packed_addressz$_IPAddressBase._check_packed_address¨sS€Ý˜'‘l”lˆ Ø ˜,Ò &Ð &ØJˆCÝ# C¨7°KØ+7¸¼ð+Hñ%HñIôIð Ið 'Ð &r có&—|j|j|z z S)z¦Turn the prefix length into a bitwise netmask Args: prefixlen: An integer, the prefix length. Returns: An integer. )rO)ÚclsÚ prefixlens rÚ_ip_int_from_prefixz"_IPAddressBase._ip_int_from_prefix¯s€ðŒ} ¤ °Ñ :Ñ;Ð;r cóÒ—t||j¦«}|j|z }||z }d|zdz }||kr4|jdz}| |d¦«}d}t||z¦«‚|S)aReturn prefix length from the bitwise netmask. Args: ip_int: An integer, the netmask in expanded bitwise format Returns: An integer, the prefix length. Raises: ValueError: If the input intermingles zeroes & ones r6éÚbigz&Netmask pattern %r mixes zeroes & ones)rErNr&r) r�Úip_intÚtrailing_zeroesr‘Ú leading_onesÚall_onesÚbyteslenÚdetailsrˆs rÚ_prefix_from_ip_intz"_IPAddressBase._prefix_from_ip_int¼sŠ€õ5°VØ58Ô5GñIôIˆàÔ&¨Ñ8ˆ Ø Ñ0ˆ ؘ‘N aÑ'ˆØ ˜8Ò #Ð #ØÔ)¨QÑ.ˆHØ—o’o h°Ñ6Ô6ˆGØ:ˆCݘS 7™]Ñ+Ô+Ð +ØÐr có,—d|z}t|¦«d‚)Nz%r is not a valid netmask)r)r�Ú netmask_strrˆs rÚ_report_invalid_netmaskz&_IPAddressBase._report_invalid_netmaskÕs€à)¨KÑ7ˆÝ Ñ$Ô$¨$Ð.r có>—| ¦«r| ¦«s| |¦« t|¦«}n%#t$r| |¦«YnwxYwd|cxkr |jksn| |¦«|S)a Return prefix length from a numeric string Args: prefixlen_str: The string to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask r)ÚisasciiÚisdigitrŸÚintrrN)r�Ú prefixlen_strr‘s rÚ_prefix_from_prefix_stringz)_IPAddressBase._prefix_from_prefix_stringÚsÄ€ð×%Ò%Ñ'Ô'ð 7¨M×,AÒ,AÑ,CÔ,Cð 7Ø × 'Ò '¨ Ñ 6Ô 6Ð 6ð 7ݘMÑ*Ô*ˆIˆIøÝð 7ð 7ð 7Ø × 'Ò '¨ Ñ 6Ô 6Ð 6Ð 6Ð 6ð 7øøøà�YÐ4Ð4Ò4Ð4 #Ô"4Ò4Ð4Ð4Ð4Ø × 'Ò '¨ Ñ 6Ô 6Ð 6ØÐs¿AÁA1Á0A1cóR— | |¦«}n%#t$r| |¦«YnwxYw | |¦«S#t$rYnwxYw||jz} | |¦«S#t$r| |¦«YdSwxYw)aTurn a netmask/hostmask string into a prefix length Args: ip_str: The netmask/hostmask to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask/hostmask N)Ú_ip_int_from_stringrrŸrœrrO)r�Úip_strr–s rÚ_prefix_from_ip_stringz%_IPAddressBase._prefix_from_ip_stringósé€ð 0Ø×,Ò,¨VÑ4Ô4ˆFˆFøÝ ð 0ð 0ð 0Ø × 'Ò '¨Ñ /Ô /Ð /Ð /Ð /ð 0øøøð  Ø×*Ò*¨6Ñ2Ô2Ð 2øÝð ð ð Ø ˆDð øøøð �#”-шð 0Ø×*Ò*¨6Ñ2Ô2Ð 2øÝð 0ð 0ð 0Ø × 'Ò '¨Ñ /Ô /Ð /Ð /Ð /Ð /ð 0øøøs/‚˜:¹:¾AÁ A ÁA Á.BÂB&Â%B&cóÜ—t|ttf¦«r ||jfSt|t¦«st |¦«}t |¦«dkr|S|d|jfS)zµHelper function to parse address of Network/Interface. Arg: address: Argument of Network/Interface. Returns: (addr, prefix) tuple. r6r)rJÚbytesr£rNÚtupler4r2)r�rs rÚ_split_addr_prefixz!_IPAddressBase._split_addr_prefixss€õ �g¥¥s˜|Ñ ,Ô ,ð /ؘCÔ.Ð.Ð .å˜'¥5Ñ)Ô)ð 7õ.¨gÑ6Ô6ˆGõ ˆw‰<Œ<˜!Ò Ð ØˆNØ�qŒz˜3Ô-Ð-Ð-r có0—|jt|¦«ffS©N©Ú __class__r0rzs rÚ __reduce__z_IPAddressBase.__reduce__-s€ØŒ~¥ D¡ ¤ ˜|Ð+Ð+r N)rr r r Ú __slots__Úpropertyr|rr‚rMrŠrŽÚ classmethodr’rœrŸr¥r©r­r²r r rrwrws\€€€€€àÐà€Ià ð3ð3ñ„Xð3ðððñ„Xððð'ð'ñ„Xð'ðð'ð'ñ„Xð'ð;ð;ð;ðIðIðIðð <ð <ñ„[ð <ðððñ„[ðð0ð/ð/ñ„[ð/ðððñ„[ðð0ð0ð0ñ„[ð0ðBð.ð.ñ„[ð.ð.,ð,ð,ð,ð,r rwcób‡—eZdZdZdZd„Zd„Zd„Zd„Zd„Z d„Z d „Z d „Z d „Z d „Zˆfd „ZˆxZS)rKz€A generic IP object. This IP class contains the version independent methods which are used by single IP addresses. r có—|jSr¯)r9rzs rÚ__int__z_BaseAddress.__int__>s €ØŒxˆr cór— |j|jko|j|jkS#t$r tcYSwxYwr¯)r9rergrs©r{Úothers rÚ__eq__z_BaseAddress.__eq__AsP€ð "Ø”H ¤ Ò)ð8Øœ ¨¬Ò7ð 9øåð "ð "ð "Ý!Ð !Ð !Ð !ð "øøøs ‚"¢6µ6cóÈ—t|t¦«stS|j|jkrt |›d|›d�¦«‚|j|jkr|j|jkSdS©NrGrHF)rJrKrsrerLr9rºs rÚ__lt__z_BaseAddress.__lt__Hsp€Ý˜%¥Ñ.Ô.ð "Ý!Ð !Ø Œ=˜EœNÒ *Ð *ÝØ!˜T˜T 5 5 5ð*ñ+ô+ð +à Œ8�u”yÒ Ð Ø”8˜eœiÒ'Ð '؈ur có„—t|t¦«stS| t|¦«|z¦«Sr¯©rJr£rsr±rºs rÚ__add__z_BaseAddress.__add__Tó7€Ý˜%¥Ñ%Ô%ð "Ý!Ð !Ø�~Š~�c $™iœi¨%Ñ/Ñ0Ô0Ð0r có„—t|t¦«stS| t|¦«|z ¦«Sr¯rÁrºs rÚ__sub__z_BaseAddress.__sub__YrÃr có@—|jj›dt|¦«›d�S©Nú(ú)©r±rr0rzs rÚ__repr__z_BaseAddress.__repr__^ó"€Øœ>Ô2Ð2Ð2µC¸±I´I°I°IÐ>Ð>r cóP—t| |j¦«¦«Sr¯)r0Ú_string_from_ip_intr9rzs rÚ__str__z_BaseAddress.__str__as €Ý�4×+Ò+¨D¬HÑ5Ô5Ñ6Ô6Ð6r có^—ttt|j¦«¦«¦«Sr¯)ÚhashÚhexr£r9rzs rÚ__hash__z_BaseAddress.__hash__ds €Ý•C�˜DœH™ œ Ñ&Ô&Ñ'Ô'Ð'r có—|j|fSr¯©rerzs rrrz_BaseAddress._get_address_keygs€Ø” ˜tÐ$Ð$r có —|j|jffSr¯)r±r9rzs rr²z_BaseAddress.__reduce__js€ØŒ~ ¤˜{Ð*Ð*r có•—|r |ddkrtt|¦«|¦«St€ddl}| d¦«at |¦«}|s!t ¦« |¦«S| ¦«\}}}|dkr|j dkrd}nd }|dkr|j }n |j dz}|r ||dzd z z }|r|d z }tt|¦«|›d |›|›|›�¦«S) aðReturns an IP address as a formatted string. Supported presentation types are: 's': returns the IP address as a string (default) 'b': converts to binary and returns a zero-padded string 'X' or 'x': converts to upper- or lower-case hex and returns a zero-padded string 'n': the same as 'b' for IPv4 and 'x' for IPv6 For binary and hex presentation types, the alternate form specifier '#' and the grouping option '_' are supported. rdÚsNrz(#?)(_?)([xbnX])Únr$ÚbÚxr6r/Ú0) Úformatr0Ú_address_fmt_reÚreÚcompileÚ fullmatchÚsuperÚ __format__ÚgroupsrerNr£) r{ÚfmtrßÚmÚ alternateÚgroupingÚfmt_baseÚpadlenr±s €rrãz_BaseAddress.__format__ms6ø€ðð *�c˜"”g ’n�nÝ�#˜d™)œ) SÑ)Ô)Ð )õ Ð "Ø ˆIˆIˆIØ ŸjšjÐ);Ñ<Ô<ˆOå × %Ò % cÑ *Ô *ˆØð +Ý‘7”7×%Ò% cÑ*Ô*Ð *à()¯ª© ¬ Ñ%ˆ �8˜Xð �sŠ?ˆ?ØŒ} Ò!Ð!Ø��à�à �sŠ?ˆ?ØÔ(ˆFˆFàÔ(¨AÑ-ˆFà ð &Ø �f ‘k A‘oÑ %ˆFà ð Ø �a‰KˆFå•c˜$‘i”i IÐ!LÐ!L°Ð!L¸Ð!LÀ(Ð!LÐ!LÑMÔMÐMr )rr r r r³r¸r¼r¿rÂrÅrËrÏrÓrrr²rãÚ __classcell__©r±s@rrKrK3sèø€€€€€ððð €Iðððð"ð"ð"ðððð1ð1ð1ð 1ð1ð1ð ?ð?ð?ð7ð7ð7ð(ð(ð(ð%ð%ð%ð+ð+ð+ð/Nð/Nð/Nð/Nð/Nð/Nð/Nð/Nð/Nr rKcóð—eZdZdZd„Zd„Zd„Zd„Zd„Zd„Z d„Z d „Z d „Z d „Z ejd „¦«Zejd „¦«Zed„¦«Zed„¦«Zed„¦«Zed„¦«Zed„¦«Zed„¦«Zd„Zd„Zd„Zd%d„Zd%d„Zed„¦«Zed„¦«Z d„Z!d„Z"ed„¦«Z#ed „¦«Z$ed!„¦«Z%ed"„¦«Z&ed#„¦«Z'ed$„¦«Z(dS)&rpz}A generic IP network object. This IP class contains the version independent methods which are used by networks. có@—|jj›dt|¦«›d�SrÇrÊrzs rrËz_BaseNetwork.__repr__§rÌr có$—d|j|jfzS©Nú%s/%d)rhr‘rzs rrÏz_BaseNetwork.__str__ªs€Ø˜$Ô.°´Ð?Ñ?Ð?r c#ó´K—t|j¦«}t|j¦«}t|dz|¦«D]}| |¦«V—ŒdS)zŸGenerate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the network or broadcast addresses. r6N©r£rhr^ÚrangeÚ_address_class©r{ÚnetworkÚ broadcastrÛs rÚhostsz_BaseNetwork.hosts­slèè€õ�dÔ*Ñ+Ô+ˆÝ˜Ô.Ñ/Ô/ˆ Ý�w ‘{ IÑ.Ô.ð )ð )ˆAØ×%Ò% aÑ(Ô(Ð (Ð (Ð (Ð (ð )ð )r c#ó´K—t|j¦«}t|j¦«}t||dz¦«D]}| |¦«V—ŒdS)Nr6rórös rÚ__iter__z_BaseNetwork.__iter__¹sjèè€Ý�dÔ*Ñ+Ô+ˆÝ˜Ô.Ñ/Ô/ˆ Ý�w  ¨A¡ Ñ.Ô.ð )ð )ˆAØ×%Ò% aÑ(Ô(Ð (Ð (Ð (Ð (ð )ð )r có(—t|j¦«}t|j¦«}|dkr0||z|krtd¦«‚| ||z¦«S|dz }||z|krtd¦«‚| ||z¦«S)Nrzaddress out of ranger6)r£rhr^Ú IndexErrorrõ)r{rÙr÷røs rÚ __getitem__z_BaseNetwork.__getitem__¿s €Ý�dÔ*Ñ+Ô+ˆÝ˜Ô.Ñ/Ô/ˆ Ø �Š6ˆ6ؘ‰{˜YÒ&Ð&Ý Ð!7Ñ8Ô8Ð8Ø×&Ò& w°¡{Ñ3Ô3Ð 3à �‰FˆAؘ1‰}˜wÒ&Ð&Ý Ð!7Ñ8Ô8Ð8Ø×&Ò& y°1¡}Ñ5Ô5Ð 5r có—t|t¦«stS|j|jkrt |›d|›d�¦«‚|j|jkr|j|jkS|j|jkr|j|jkSdSr¾)rJrprsrerLrhÚnetmaskrºs rr¿z_BaseNetwork.__lt__Ìs’€Ý˜%¥Ñ.Ô.ð "Ý!Ð !Ø Œ=˜EœNÒ *Ð *ÝØ!˜T˜T 5 5 5ð*ñ+ô+ð +à Ô  5Ô#8Ò 8Ð 8ØÔ'¨%Ô*?Ò?Ð ?Ø Œ<˜5œ=Ò (Ð (Ø”< %¤-Ò/Ð /؈ur cóÆ— |j|jko9|j|jko)t|j¦«t|j¦«kS#t$r t cYSwxYwr¯)rerhr£rrgrsrºs rr¼z_BaseNetwork.__eq__Øsu€ð "Ø”M U¤^Ò3ð<ØÔ(¨EÔ,AÒAð<嘜 Ñ%Ô%­¨U¬]Ñ);Ô);Ò;ð =øõð "ð "ð "Ý!Ð !Ð !Ð !ð "øøøs‚A A Á A ÁA cól—tt|j¦«t|j¦«f¦«Sr¯)rÑr£rhrrzs rrÓz_BaseNetwork.__hash__às*€Ý•S˜Ô-Ñ.Ô.µ°D´LÑ0AÔ0AÐBÑCÔCÐCr có˜—|j|jkrdSt|t¦«rdS|j|jjz|jjkS©NF)rerJrpr9rrhrºs rÚ __contains__z_BaseNetwork.__contains__ãsM€à Œ=˜EœNÒ *Ð *Ø�5å �e�\Ñ *Ô *ð LØ�5ð”9˜tœ|Ô/Ñ/°4Ô3GÔ3KÒKÐ Kr cóJ—|j|vp|j|vp|j|vp|j|vS)z*Tell if self is partly contained in other.©rhr^rºs rÚoverlapsz_BaseNetwork.overlapsïsB€àÔ# uÐ,ð7Ø Ô " eÐ +ð 6ØÔ%¨Ð-ð5ØÔ+¨tÐ3ð 7r cóz—| t|j¦«t|j¦«z¦«Sr¯)rõr£rhÚhostmaskrzs rr^z_BaseNetwork.broadcast_addressös9€à×"Ò"¥3 tÔ';Ñ#<Ô#<Ý#& t¤}Ñ#5Ô#5ñ$6ñ7ô7ð 7r có`—| t|j¦«|jz ¦«Sr¯)rõr£rrOrzs rr z_BaseNetwork.hostmaskûs'€à×"Ò"¥3 t¤|Ñ#4Ô#4°t´~Ñ#EÑFÔFÐFr có$—d|j|jfzSrð)rhrfrzs rÚwith_prefixlenz_BaseNetwork.with_prefixlenÿs€à˜$Ô.°´Ð@Ñ@Ð@r có$—|j›d|j›�S©Nr.)rhrrzs rÚ with_netmaskz_BaseNetwork.with_netmasks€àÔ.Ð.Ð.°´ ° Ð=Ð=r có$—|j›d|j›�Sr)rhr rzs rÚ with_hostmaskz_BaseNetwork.with_hostmasks€àÔ.Ð.Ð.°´ ° Ð>Ð>r cóZ—t|j¦«t|j¦«z dzS)z&Number of hosts in the current subnet.r6)r£r^rhrzs rÚ num_addressesz_BaseNetwork.num_addresses s*€õ�4Ô)Ñ*Ô*­S°Ô1EÑ-FÔ-FÑFÈÑJÐJr cóF—dt|¦«fz}t|¦«‚)Nz%%200s has no associated address classr„r‡s rrõz_BaseNetwork._address_classs$€ð 6½¸d¹¼¸ ÑEˆÝ! #Ñ&Ô&Ð&r có—|jSr¯)rfrzs rr‘z_BaseNetwork.prefixlens €àŒÐr c#óúK—|j|jkst|›d|›d�¦«‚t|t¦«std|z¦«‚| |¦«st |›d|›�¦«‚||krdS| |j›d|j›�¦«}|  ¦«\}}||krŒ||kr†| |¦«r|V—|  ¦«\}}nI| |¦«r|V—|  ¦«\}}ntd|›d|›d |›�¦«‚||kr||k°†||kr|V—dS||kr|V—dStd|›d|›d |›�¦«‚) aºRemove an address from a larger block. For example: addr1 = ip_network('192.0.2.0/28') addr2 = ip_network('192.0.2.1/32') list(addr1.address_exclude(addr2)) = [IPv4Network('192.0.2.0/32'), IPv4Network('192.0.2.2/31'), IPv4Network('192.0.2.4/30'), IPv4Network('192.0.2.8/29')] or IPv6: addr1 = ip_network('2001:db8::1/32') addr2 = ip_network('2001:db8::1/128') list(addr1.address_exclude(addr2)) = [ip_network('2001:db8::1/128'), ip_network('2001:db8::2/127'), ip_network('2001:db8::4/126'), ip_network('2001:db8::8/125'), ... ip_network('2001:db8:8000::/33')] Args: other: An IPv4Network or IPv6Network object of the same type. Returns: An iterator of the IPv(4|6)Network objects which is self minus other. Raises: TypeError: If self and other are of differing address versions, or if other is not a network object. ValueError: If other is not completely contained by self. rGrHz%s is not a network objectz not contained in Nr.z Error performing exclusion: s1: z s2: z other: ) rerLrJrpÚ subnet_ofrr±rhr‘r`ÚAssertionError)r{r»Ús1Ús2s rÚaddress_excludez_BaseNetwork.address_excludesêèè€ðHŒ} ¤Ò.Ð.ÝØ!˜T˜T 5 5 5ð*ñ+ô+ð +õ˜%¥Ñ.Ô.ð BÝÐ8¸5Ñ@ÑAÔAÐ Aà�Š˜tÑ$Ô$ð Gݸ¸¸ÀÀÐEÑFÔFÐ FØ �DŠ=ˆ=Ø ˆFð—’¨5Ô+@Ð+@Ð+@Ø+0¬?¨?ð!<ñ=ô=ˆð—’‘”‰ˆˆBØ�EŠkˆk˜b Ešk˜kØ�Š˜rÑ"Ô"ð 6Ø���ØŸš™œ‘��B�BØ—’ Ñ$Ô$ð 6Ø���ØŸš™œ‘��B�Bõ%�nà&( b b¨"¨"¨"¨e¨eð&5ñ6ô6ð6ð�EŠkˆk˜b Ešk˜kð �Š;ˆ;؈HˆHˆHˆHˆHØ �5Š[ˆ[؈HˆHˆHˆHˆHõ!�.à"$ " " b b b¨%¨%ð"1ñ2ô2ð 2r cóà—|j|jkrt|›d|›d�¦«‚|j|jkrdS|j|jkrdS|j|jkrdS|j|jkrdSdS)a¥Compare two IP objects. This is only concerned about the comparison of the integer representation of the network addresses. This means that the host bits aren't considered at all in this method. If you want to compare host bits, you can easily enough do a 'HostA._ip < HostB._ip' Args: other: An IP object. Returns: If the IP versions of self and other are the same, returns: -1 if self < other: eg: IPv4Network('192.0.2.0/25') < IPv4Network('192.0.2.128/25') IPv6Network('2001:db8::1000/124') < IPv6Network('2001:db8::2000/124') 0 if self == other eg: IPv4Network('192.0.2.0/24') == IPv4Network('192.0.2.0/24') IPv6Network('2001:db8::1000/124') == IPv6Network('2001:db8::1000/124') 1 if self > other eg: IPv4Network('192.0.2.128/25') > IPv4Network('192.0.2.0/25') IPv6Network('2001:db8::2000/124') > IPv6Network('2001:db8::1000/124') Raises: TypeError if the IP versions are different. rGz are not of the same typerdr6r)rerLrhrrºs rÚcompare_networksz_BaseNetwork.compare_networksgs“€ðB Œ=˜EœNÒ *Ð *ÝØ!˜T˜T 5 5 5ð*ñ+ô+ð +ð Ô  %Ô"7Ò 7Ð 7Ø�2Ø Ô  %Ô"7Ò 7Ð 7Ø�1à Œ<˜%œ-Ò 'Ð 'Ø�2Ø Œ<˜%œ-Ò 'Ð 'Ø�1؈qr có*—|j|j|jfS)zËNetwork-only key function. Returns an object that identifies this address' network and netmask. This function is a suitable "key" argument for sorted() and list.sort(). )rerhrrzs rrqz_BaseNetwork._get_networks_key—s€ð” ˜tÔ3°T´\ÐBÐBr r6Nc#óK—|j|jkr|V—dS|�9||jkrtd¦«‚|dkrtd¦«‚||jz }|dkrtd¦«‚|j|z}||jkrtd||fz¦«‚t|j¦«}t|j¦«dz}t|j¦«dz|z }t|||¦«D]}| ||f¦«}|V—ŒdS)aÓThe subnets which join to make the current subnet. In the case that self contains only one IP (self._prefixlen == 32 for IPv4 or self._prefixlen == 128 for IPv6), yield an iterator with just ourself. Args: prefixlen_diff: An integer, the amount the prefix length should be increased by. This should not be set if new_prefix is also set. new_prefix: The desired new prefix length. This must be a larger number (smaller prefix) than the existing prefix. This should not be set if prefixlen_diff is also set. Returns: An iterator of IPv(4|6) objects. Raises: ValueError: The prefixlen_diff is too small or too large. OR prefixlen_diff and new_prefix are both set or new_prefix is a smaller number than the current prefix (smaller number means a larger network) Nznew prefix must be longerr6ú(cannot set prefixlen_diff and new_prefixrzprefix length diff must be > 0z0prefix length diff %d is invalid for netblock %s) rfrNrr£rhr^r rôr±) r{Úprefixlen_diffÚ new_prefixÚ new_prefixlenÚstartÚendÚstepÚnew_addrÚcurrents rr`z_BaseNetwork.subnets¡sMèè€ð4 Œ?˜dÔ1Ò 1Ð 1؈JˆJˆJØ ˆFà Ð !ؘDœOÒ+Ð+Ý Ð!<Ñ=Ô=Ð=Ø Ò"Ð"Ý Ð!KÑLÔLÐLØ'¨$¬/Ñ9ˆNà ˜AÒ Ð ÝÐ=Ñ>Ô>Ð >Øœ¨.Ñ8ˆ à ˜4Ô.Ò .Ð .ÝØBØ! 4ðF)ñ)ñ*ô*ð *õ�DÔ(Ñ)Ô)ˆÝ�$Ô(Ñ)Ô)¨AÑ-ˆÝ�D”MÑ"Ô" QÑ&¨>Ñ9ˆÝ˜e S¨$Ñ/Ô/ð ð ˆHØ—n’n h° Ð%>Ñ?Ô?ˆG؈MˆMˆMˆMð ð r cóf—|jdkr|S|�9||jkrtd¦«‚|dkrtd¦«‚|j|z }|j|z }|dkrtd|j|fz¦«‚| t |j¦«t |j¦«|zz|f¦«S)aËThe supernet containing the current network. Args: prefixlen_diff: An integer, the amount the prefix length of the network should be decreased by. For example, given a /24 network and a prefixlen_diff of 3, a supernet with a /21 netmask is returned. Returns: An IPv4 network object. Raises: ValueError: If self.prefixlen - prefixlen_diff < 0. I.e., you have a negative prefix length. OR If prefixlen_diff and new_prefix are both set or new_prefix is a larger number than the current prefix (larger number means a smaller network) rNznew prefix must be shorterr6r!z;current prefixlen is %d, cannot have a prefixlen_diff of %d)rfrr‘r±r£rhr)r{r"r#r$s rrYz_BaseNetwork.supernetÖsÛ€ð* Œ?˜aÒ Ð ØˆKà Ð !ؘDœOÒ+Ð+Ý Ð!=Ñ>Ô>Ð>Ø Ò"Ð"Ý Ð!KÑLÔLÐLØ!œ_¨zÑ9ˆNàœ¨Ñ7ˆ Ø ˜1Ò Ð ÝØMØ” Ð0ñ1ñ2ô2ð 2ð�~Š~Ý �Ô$Ñ %Ô %­¨T¬\Ñ):Ô):¸nÑ)LÑ MØ ðñôð r có2—|jjo |jjS©z»Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )rhÚ is_multicastr^rzs rr-z_BaseNetwork.is_multicastÿs €ðÔ$Ô1ð4ØÔ&Ô3ð 5r cóÔ— |j|jkrt|›d|›d�¦«‚|j|jko|j|jkS#t$rtd|›d|›�¦«‚wxYw)NrGrHz*Unable to test subnet containment between )rerLrhr^rg)ÚarÚs rÚ _is_subnet_ofz_BaseNetwork._is_subnet_of s¨€ð 4àŒz˜QœZÒ'Ð'Ý 1Ð JÐ J¨1Ð JÐ JÐ JÑKÔKÐKØÔ%¨Ô):Ò:ð?ØÔ'¨1Ô+>Ò>ð @øåð 4ð 4ð 4Ýð3Ø'(ð3ð3Ø/0ð3ð3ñ4ô4ð 4ð 4øøøs ‚AAÁ A'có.—| ||¦«S)z1Return True if this network is a subnet of other.©r0rºs rrz_BaseNetwork.subnet_ofs€à×!Ò! $¨Ñ.Ô.Ð.r có.—| ||¦«S)z3Return True if this network is a supernet of other.r2rºs rÚ supernet_ofz_BaseNetwork.supernet_ofs€à×!Ò! %¨Ñ.Ô.Ð.r có2—|jjo |jjS)úµTest if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. )rhÚ is_reservedr^rzs rr7z_BaseNetwork.is_reservedó €ðÔ$Ô0ð3ØÔ&Ô2ð 4r có2—|jjo |jjS©z�Test if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. )rhÚ is_link_localr^rzs rr;z_BaseNetwork.is_link_local+s €ðÔ$Ô2ð5ØÔ&Ô4ð 6r c󘇗tˆfd„‰jjD¦«¦«o$tˆfd„‰jjD¦«¦«S)zÍTest if this network belongs to a private range. Returns: A boolean, True if the network is reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. c3ó<•K—|]}‰j|vo‰j|vV—ŒdSr¯r)Ú.0Ú priv_networkr{s €rú z*_BaseNetwork.is_private..?sWøèè€ðJðJà#ðÔ'¨<Ð7ð:ØÔ)¨\Ð9ðJðJðJðJðJðJr c3ó<•K—|]}‰j|vo‰j|vV—ŒdSr¯r)r>r÷r{s €rr@z*_BaseNetwork.is_private..AsYøèè€ðRðRð ðÔ(°Ð7ð:ØÔ*°'Ð9ðRðRðRðRðRðRr ©ÚanyÚ _constantsÚ_private_networksÚallÚ_private_networks_exceptionsrzs`rÚ is_privatez_BaseNetwork.is_private6s“ø€õðJðJðJðJà'+¤Ô'HðJñJôJñJôJðåNQðRðRðRðRð$(¤?Ô#OðRñRôRñOôOð r có—|j S)z×Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )rHrzs rÚ is_globalz_BaseNetwork.is_globalGs€ð”?Ð"Ð"r có2—|jjo |jjS)ú¨Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. )rhÚis_unspecifiedr^rzs rrMz_BaseNetwork.is_unspecifiedRs €ðÔ$Ô3ð6ØÔ&Ô5ð 7r có2—|jjo |jjS)ú±Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. )rhÚ is_loopbackr^rzs rrPz_BaseNetwork.is_loopback^r8r )r6N))rr r r rËrÏrùrûrþr¿r¼rÓrrÚ functoolsÚcached_propertyr^r r´r rrrrõr‘rrrqr`rYr-Ú staticmethodr0rr4r7r;rHrJrMrPr r rrprpŸsû€€€€€ððð ?ð?ð?ð@ð@ð@ð )ð )ð )ð)ð)ð)ð 6ð 6ð 6ð ð ð ð"ð"ð"ðDðDðDð Lð Lð Lð7ð7ð7ðÔð7ð7ñÔð7ðÔðGðGñÔðGððAðAñ„XðAðð>ð>ñ„Xð>ðð?ð?ñ„Xð?ððKðKñ„XðKðð'ð'ñ„Xð'ðððñ„XððI2ðI2ðI2ðV.ð.ð.ð`CðCðCð3ð3ð3ð3ðj'ð'ð'ð'ðRð 5ð 5ñ„Xð 5ðð 4ð 4ñ„\ð 4ð/ð/ð/ð/ð/ð/ðð 4ð 4ñ„Xð 4ðð6ð6ñ„Xð6ðððñ„Xðð ð#ð#ñ„Xð#ðð 7ð 7ñ„Xð 7ðð 4ð 4ñ„Xð 4ð 4ð 4r rpcó—eZdZgZdS)Ú_BaseConstantsN)rr r rEr r rrUrUks€€€€€àÐÐÐr rUcó—eZdZdZdZdZdezdz ZeZiZ d„Z e d„¦«Z e d„¦«Z e d „¦«Ze d „¦«Zd „Zed „¦«Zed „¦«ZdS)Ú_BaseV4zyBase IPv4 object. The following methods are used by IPv4 objects in both single IP addresses and networks. r r$r/r6có —t|¦«Sr¯r~rzs rryz$_BaseV4._explode_shorthand_ip_string†s€Ý�4‰yŒyÐr có„—||jvr«t|t¦«r,|}d|cxkr |jksn| |¦«n< | |¦«}n%#t $r| |¦«}YnwxYwt|  |¦«¦«}||f|j|<|j|S©aMake a (netmask, prefix_len) tuple from the given argument. Argument can be: - an integer (the prefix length) - a string representing the prefix length (e.g. "24") - a string representing the prefix netmask (e.g. "255.255.255.0") r) Ú_netmask_cacherJr£rNrŸr¥rr©rr’©r�Úargr‘rs rÚ _make_netmaskz_BaseV4._make_netmask‰sñ€ð �cÔ(Ð (Ð (ݘ#�sÑ#Ô#ð @Ø� ؘYÐ<Ð<Ò<Ð<¨#Ô*<Ò<Ð<Ð<Ð<Ø×/Ò/° Ñ:Ô:Ð:øð@à #× >Ò >¸sÑ CÔ C�I�IøÝ(ð@ð@ð@ð!$× :Ò :¸3Ñ ?Ô ?�I�I�Ið@øøøõ" #×"9Ò"9¸)Ñ"DÔ"DÑEÔEˆGØ&-¨yÐ&8ˆCÔ ˜sÑ #ØÔ! #Ô&Ð&sÁ A"Á"BÂBcóD—|std¦«‚| d¦«}t|¦«dkrtd|z¦«‚ t t |j|¦«d¦«S#t$r}t|›d|›�¦«d‚d}~wwxYw)aTurn the given IP string into an integer for comparison. Args: ip_str: A string, the IP ip_str. Returns: The IP ip_str as an integer. Raises: AddressValueError: if ip_str isn't a valid IPv4 Address. úAddress cannot be emptyú.r$zExpected 4 octets in %rr•ú in N)rr1r2r£Ú from_bytesÚmapÚ _parse_octetr)r�r¨ÚoctetsÚexcs rr§z_BaseV4._ip_int_from_string£s¶€ðð ?Ý#Ð$=Ñ>Ô>Ð >à—’˜cÑ"Ô"ˆÝ ˆv‰;Œ;˜!Ò Ð Ý#Ð$=ÀÑ$FÑGÔGÐ Gð JÝ—>’>¥# cÔ&6¸Ñ"?Ô"?ÀÑGÔGÐ GøÝð Jð Jð JÝ#°#°#°#°v°vÐ$>Ñ?Ô?ÀTÐ Iøøøøð JøøøsÁ -A;Á; BÂBÂBcóŠ—|std¦«‚| ¦«r| ¦«sd}t||z¦«‚t|¦«dkrd}t||z¦«‚|dkr |ddkrd}t||z¦«‚t |d¦«}|d krtd |z¦«‚|S) a Convert a decimal octet into an integer. Args: octet_str: A string, the number to parse. Returns: The octet as an integer. Raises: ValueError: if the octet isn't strictly a decimal from [0..255]. zEmpty octet not permittedz#Only decimal digits permitted in %réz$At most 3 characters permitted in %rrÜrz%Leading zeros are not permitted in %ré éÿzOctet %d (> 255) not permitted)rr¡r¢r2r£)r�Ú octet_strrˆÚ octet_ints rrez_BaseV4._parse_octet½sç€ðð :ÝÐ8Ñ9Ô9Ð 9à×!Ò!Ñ#Ô#ð .¨ ×(9Ò(9Ñ(;Ô(;ð .Ø7ˆCݘS 9™_Ñ-Ô-Ð -õ ˆy‰>Œ>˜AÒ Ð Ø8ˆCݘS 9™_Ñ-Ô-Ð -ð ˜Ò Ð   ¨!¤ °Ò 3Ð 3Ø9ˆCݘS 9™_Ñ-Ô-Ð -å˜  2Ñ&Ô&ˆ Ø �sŠ?ˆ?ÝÐ=À ÑIÑJÔJÐ JØÐr c óz—d tt| dd¦«¦«¦«S)zÒTurns a 32-bit integer into dotted decimal notation. Args: ip_int: An integer, the IP address. Returns: The IP address as a string in dotted decimal notation. rar$r•)Újoinrdr0r&)r�r–s rrÎz_BaseV4._string_from_ip_intás.€ð�xŠx��C §¢°°EÑ!:Ô!:Ñ;Ô;Ñ<Ô<ÐrTr{s €rr@z)IPv4Address.is_private..Kó'øèè€ÐIÐI �˜� ÐIÐIÐIÐIÐIÐIr c3ó •K—|]}‰|vV—Œ dSr¯r r‰s €rr@z)IPv4Address.is_private..Ló'øèè€Ð\Ð\¨�D �OÐ\Ð\Ð\Ð\Ð\Ð\r rBrzs`rrHzIPv4Address.is_private9sZø€õ$ ÐIÐIÐIÐI t¤Ô'HÐIÑIÔIÑ IÔ Ið ]ÝÐ\Ð\Ð\Ð\¨t¬Ô/[Ð\Ñ\Ô\Ñ\Ô\ð r có.—||jjvo|j S©ar``True`` if the address is defined as globally reachable by iana-ipv4-special-registry_ (for IPv4) or iana-ipv6-special-registry_ (for IPv6) with the following exception: For IPv4-mapped IPv6-addresses the ``is_private`` value is determined by the semantics of the underlying IPv4 addresses and the following condition holds (see :attr:`IPv6Address.ipv4_mapped`):: address.is_global == address.ipv4_mapped.is_global ``is_global`` has value opposite to :attr:`is_private`, except for the ``100.64.0.0/10`` IPv4 range where they are both ``False``. )rDÚ_public_networkrHrzs rrJzIPv4Address.is_globalOs€ð ˜4œ?Ô:Ð:ÐRÀ4Ä?Ð?RÐRr có—||jjvS)z­Test if the address is reserved for multicast use. Returns: A boolean, True if the address is multicast. See RFC 3171 for details. )rDÚ_multicast_networkrzs rr-zIPv4Address.is_multicastas€ð�t”Ô9Ð9Ð9r có"—||jjkS)z¤Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 5735 3. )rDÚ_unspecified_addressrzs rrMzIPv4Address.is_unspecifiedls€ð�t”Ô;Ò;Ð;r có—||jjvS)z�Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback per RFC 3330. )rDÚ_loopback_networkrzs rrPzIPv4Address.is_loopbackws€ð�t”Ô8Ð8Ð8r có—||jjvS)z’Test if the address is reserved for link-local. Returns: A boolean, True if the address is link-local per RFC 3927. )rDÚ_linklocal_networkrzs rr;zIPv4Address.is_link_local�s€ð�t”Ô9Ð9Ð9r N)rr r r r³rr´r‚r7rQÚ lru_cacherHrJr-rMrPr;r r rrrs6€€€€€à9Ð9à&€Ið!6ð!6ð!6ðFð*ð*ñ„Xð*ðð9ð9ñ„Xð9ðØ€YÔÑÔð ð ñÔñ„Xð ð(Ø€YÔÑÔðSðSñÔñ„XðSð ð:ð:ñ„Xð:ðð<ð<ñ„Xð<ðð9ð9ñ„Xð9ðð:ð:ñ„Xð:ð:ð:r rcó²—eZdZd„Zejd„¦«Zd„Zd„Zd„Z d„Z e j Z e d„¦«Ze d„¦«Ze d „¦«Ze d „¦«Zd S) r cóà—| |¦«\}}t ||¦«t||fd¬¦«|_|jj|_|jj|_dS©NF)r)r­rrrr÷rrf©r{rr3Úmasks rrzIPv4Interface.__init__Žóc€Ø×,Ò,¨WÑ5Ô5‰ ˆˆdå×Ò˜T 4Ñ(Ô(Ð(Ý" D¨$ <¸Ð>Ñ>Ô>ˆŒ Ø”|Ô+ˆŒ Øœ,Ô1ˆŒˆˆr có—|jjSr¯©r÷r rzs rr zIPv4Interface.hostmask–ó €àŒ|Ô$Ð$r cóJ—d| |j¦«|jfzSrð©rÎr9rfrzs rrÏzIPv4Interface.__str__šs+€Ø˜$×2Ò2°4´8Ñ<Ô<Øœ/ð+ñ+ð +r có–—t ||¦«}|tus|s|S |j|jkS#t$rYdSwxYwr)rr¼rsr÷rg©r{r»Ú address_equals rr¼zIPv4Interface.__eq__žóe€Ý#×*Ò*¨4°Ñ7Ô7ˆ Ø �NÐ *Ð *°-Ð *Ø Ð ð Ø”< 5¤=Ò0Ð 0øÝð ð ð ð�5�5ð  øøøóª:º AÁAcóÀ—t ||¦«}|turtS |j|jkp|j|jko|S#t$rYdSwxYwr)rr¿rsr÷rg©r{r»Ú address_lesss rr¿zIPv4Interface.__lt__ªsz€Ý"×)Ò)¨$°Ñ6Ô6ˆ Ø �>Ð )Ð )Ý!Ð !ð Ø”L 5¤=Ò0ðCØ”L E¤MÒ1ÐB°lð Døåð ð ð ð�5�5ð øøøs­!AÁ AÁAcóh—t|j|jt|jj¦«f¦«Sr¯©rÑr9rfr£r÷rhrzs rrÓzIPv4Interface.__hash__¶ó(€Ý�T”X˜tœµ°D´LÔ4PÑ0QÔ0QÐRÑSÔSÐSr có*—t|j¦«Sr¯)rr9rzs rr>zIPv4Interface.ip»ó€å˜4œ8Ñ$Ô$Ð$r cóJ—| |j¦«›d|j›�Srr£rzs rr zIPv4Interface.with_prefixlen¿ó,€à×2Ò2°4´8Ñ<Ô<Ð<Ð<Øœ/˜/ð+ð +r cóJ—| |j¦«›d|j›�Sr©rÎr9rrzs rrzIPv4Interface.with_netmaskÄó,€à×2Ò2°4´8Ñ<Ô<Ð<Ð<Øœ,˜,ð(ð (r cóJ—| |j¦«›d|j›�Sr©rÎr9r rzs rrzIPv4Interface.with_hostmaskÉó,€à×2Ò2°4´8Ñ<Ô<Ð<Ð<Øœ-˜-ð)ð )r N)rr r rrQrRr rÏr¼r¿rÓrwr²r´r>r rrr r rr r Œsõ€€€€€ð2ð2ð2ðÔð%ð%ñÔð%ð+ð+ð+ð ð ð ð ð ð ðTðTðTð Ô*€Jà ð%ð%ñ„Xð%ðð+ð+ñ„Xð+ðð(ð(ñ„Xð(ðð)ð)ñ„Xð)ð)ð)r r có^—eZdZdZeZdd„Zeej ¦«d„¦«¦«Z dS)raeThis class represents and manipulates 32-bit IPv4 network + addresses.. Attributes: [examples for IPv4Network('192.0.2.0/27')] .network_address: IPv4Address('192.0.2.0') .hostmask: IPv4Address('0.0.0.31') .broadcast_address: IPv4Address('192.0.2.32') .netmask: IPv4Address('255.255.255.224') .prefixlen: 27 Tcóö‡—| |¦«\Š}t‰¦«|_| |¦«\|_|_t |j¦«}|t |j¦«z|kr=|rtd|z¦«‚t|t |j¦«z¦«|_|j|jdz kr|j |_ dS|j|jkr ˆfd„|_ dSdS)aInstantiate a new IPv4 network object. Args: address: A string or integer representing the IP [& network]. '192.0.2.0/24' '192.0.2.0/255.255.255.0' '192.0.2.0/0.0.0.255' are all functionally the same in IPv4. Similarly, '192.0.2.1' '192.0.2.1/255.255.255.255' '192.0.2.1/32' are also functionally equivalent. That is to say, failing to provide a subnetmask will create an object with a mask of /32. If the mask (portion after the / in the argument) is given in dotted quad form, it is treated as a netmask if it starts with a non-zero field (e.g. /255.0.0.0 == /8) and as a hostmask if it starts with a zero field (e.g. 0.255.255.255 == /8), with the single exception of an all-zero mask which is treated as a netmask == /0. If no mask is given, a default of /32 is used. Additionally, an integer can be passed, so IPv4Network('192.0.2.1') == IPv4Network(3221225985) or, more generally IPv4Interface(int(IPv4Interface('192.0.2.1'))) == IPv4Interface('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. NetmaskValueError: If the netmask isn't valid for an IPv4 address. ValueError: If strict is True and a network address is not supplied. ú%s has host bits setr6có$•—t‰¦«gSr¯)r©r3s€rúz&IPv4Network.__init__..óø€¥+¨dÑ"3Ô"3Ð!4€r N) r­rrhr^rrfr£rrNrûrù©r{rrr�r‚r3s @rrzIPv4Network.__init__Þs ø€ðF×,Ò,¨WÑ5Ô5‰ ˆˆdå*¨4Ñ0Ô0ˆÔØ(,×(:Ò(:¸4Ñ(@Ô(@Ñ%ˆŒ �d”oÝ�TÔ)Ñ*Ô*ˆØ •C˜œ Ñ%Ô%Ñ %¨Ò /Ð /Øð FÝ Ð!7¸$Ñ!>Ñ?Ô?Ð?å'2°6Ý36°t´|Ñ3DÔ3Dñ4Eñ(Fô(F�Ô$ð Œ?˜tÔ2°QÑ6Ò 7Ð 7ØœˆDŒJˆJˆJØ Œ_ Ô!4Ò 5Ð 5Ø4Ð4Ð4Ð4ˆDŒJˆJˆJð6Ð 5r cól—|jtd¦«vo|jtd¦«v o|j S)z¹Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry. ú 100.64.0.0/10)rhrr^rHrzs rrJzIPv4Network.is_globalsH€ðÔ)­[¸Ñ-IÔ-IÐIðKØÔ*­k¸/Ñ.JÔ.JÐJðLð$à”OÐ#ð %r N©T) rr r r rrõrr´rQr˜rJr r rrrÏsk€€€€€ð ð ð!€Nð25ð25ð25ð25ðhØ€YÔÑÔð %ð %ñÔñ„Xð %ð %ð %r rcóÚ—eZdZed¦«Zed¦«Zed¦«Zed¦«Zed¦«ed¦«ed¦«ed¦«ed¦«ed¦«ed ¦«ed ¦«ed ¦«ed ¦«ed ¦«ed¦«ed¦«ed¦«gZed¦«ed¦«gZ ed¦«Z e d¦«Z dS)Ú_IPv4Constantsz169.254.0.0/16z 127.0.0.0/8z 224.0.0.0/4rÂz 0.0.0.0/8z 10.0.0.0/8z 172.16.0.0/12z 192.0.0.0/24z192.0.0.170/31z 192.0.2.0/24z192.168.0.0/16z 198.18.0.0/15z198.51.100.0/24z203.0.113.0/24z 240.0.0.0/4z255.255.255.255/32z 192.0.0.9/32z 192.0.0.10/32z0.0.0.0N) rr r rr—r•r‘r�rErGr…rr“r r rrÅrÅ!s\€€€€€Ø$˜Ð%5Ñ6Ô6Ðà#˜  MÑ2Ô2Ðà$˜ ]Ñ3Ô3Ðà!�k /Ñ2Ô2€Oð ˆ �KÑ Ô Øˆ �LÑ!Ô!؈ �MÑ"Ô"؈ Ð$Ñ%Ô%؈ �OÑ$Ô$؈ �NÑ#Ô#؈ Ð$Ñ%Ô%؈ �NÑ#Ô#؈ Ð$Ñ%Ô%؈ �OÑ$Ô$؈ Ð%Ñ&Ô&؈ Ð$Ñ%Ô%؈ �MÑ"Ô"؈ Ð(Ñ)Ô)ð Ðð$ ˆ �NÑ#Ô#؈ �OÑ$Ô$ð$Ð ð $˜  MÑ2Ô2Ðà&˜; yÑ1Ô1ÐÐÐr rÅcó —eZdZdZdZdZdezdz ZdZe d¦«Z eZ iZ e d„¦«Ze d „¦«Ze d „¦«Ze d „¦«Ze dd „¦«Zd„Zd„Zed„¦«Zed„¦«Zed„¦«Zd S)Ú_BaseV6zyBase IPv6 object. The following methods are used by IPv6 objects in both single IP addresses and networks. r rIr/r6r”Ú0123456789ABCDEFabcdefcó6—||jvr„t|t¦«r,|}d|cxkr |jksn| |¦«n| |¦«}t | |¦«¦«}||f|j|<|j|SrZ)r[rJr£rNrŸr¥rr’r\s rr^z_BaseV6._make_netmask_s¯€ð �cÔ(Ð (Ð (ݘ#�sÑ#Ô#ð @Ø� ؘYÐ<Ð<Ò<Ð<¨#Ô*<Ò<Ð<Ð<Ð<Ø×/Ò/° Ñ:Ô:Ð:øà×:Ò:¸3Ñ?Ô?� Ý! #×"9Ò"9¸)Ñ"DÔ"DÑEÔEˆGØ&-¨yÐ&8ˆCÔ ˜sÑ #ØÔ! #Ô&Ð&r cóè—|std¦«‚t|¦«dkrQ|}t|¦«dkr*|dd…›dt|¦«dz ›d|dd…›�}td |›�¦«‚|jd z}| d |¬ ¦«}d }t|¦«|krd||fz}t|¦«‚d|dvrˆ t | ¦«¦«j}n'#t$r}t|›d|›�¦«d‚d}~wwxYw| d|dz dzz¦«| d|dzz¦«t|¦«|krd|d z |fz}t|¦«‚d} td t|¦«d z ¦«D]"} || s| �d|z}t|¦«‚| } Œ#| ��| } t|¦«| z d z } |ds| d z} | rd}t||z¦«‚|ds| d z} | rd}t||z¦«‚|j| | zz } | d krd}t||jd z |fz¦«‚n~t|¦«|jkrd}t||j|fz¦«‚|dsd}t||z¦«‚|dsd}t||z¦«‚t|¦«} d} d} d}t| ¦«D]%} |dz}||  || ¦«z}Œ&|d| zz}t| d¦«D]%} |dz}||  || ¦«z}Œ&|S#t$r}t|›d|›�¦«d‚d}~wwxYw)zùTurn an IPv6 ip_str into an integer. Args: ip_str: A string, the IPv6 ip_str. Returns: An int, the IPv6 address Raises: AddressValueError: if ip_str isn't a valid IPv6 Address. r`é-édNrÈéZz chars elided)iÓÿÿÿz"At most 45 characters expected in r6ú:)Úmaxsplitriz At least %d parts expected in %rrardrbú%xr+éÿÿz!At most %d colons permitted in %rz At most one '::' permitted in %rrz0Leading ':' only permitted as part of '::' in %rz1Trailing ':' only permitted as part of '::' in %rz/Expected at most %d other parts with '::' in %rz,Exactly %d parts expected without '::' in %r) rr2Ú _HEXTET_COUNTr1rrXr9r[rôÚ _parse_hextetr)r�r¨ÚshortenÚ _max_partsÚpartsÚ _min_partsrˆÚipv4_intrgÚ skip_indexÚiÚparts_hiÚparts_loÚ parts_skippedr–s rr§z_BaseV6._ip_int_from_stringssm€ðð ?Ý#Ð$=Ñ>Ô>Ð >Ý ˆv‰;Œ;˜Ò Р؈GÝ�7‰|Œ|˜cÒ!Ð!Ø# C R Cœ[ÐWÐW­3¨v©;¬;°r©>ÐWÐWÈÐPSÐPTÐPTÌÐWÐW�Ý#ð%3Ø'.ð%3ð%3ñ4ô4ð 4ð Ô&¨Ñ*ˆ Ø— ’ ˜S¨:� Ñ6Ô6ˆðˆ Ý ˆu‰:Œ:˜ Ò "Ð "Ø4¸ ÀFÐ7KÑKˆCÝ# CÑ(Ô(Ð (ð �%˜”)Ð Ð ð NÝ& u§y¢y¡{¤{Ñ3Ô3Ô7��øÝ$ð Nð Nð NÝ'°c°c°c¸6¸6Ð(BÑCÔCÈÐMøøøøð Nøøøà �LŠL˜ (¨b¡.°FÑ!:Ñ;Ñ <Ô <Ð <Ø �LŠL˜ ¨FÑ!2Ñ3Ñ 4Ô 4Ð 4õ ˆu‰:Œ:˜ Ò "Ð "Ø5¸ÀA¹ÀvÐ8NÑNˆCÝ# CÑ(Ô(Ð (ðˆ Ý�q�#˜e™*œ* q™.Ñ)Ô)ð ð ˆAؘ”8ð ØÐ)à<¸vÑE�CÝ+¨CÑ0Ô0Ð0Ø� øð Ð !à!ˆHݘ5‘z”z JÑ.°Ñ2ˆHؘ”8ð :ؘA‘ �Øð:ØL�CÝ+¨C°&©LÑ9Ô9Ð9ؘ”9ð :ؘA‘ �Øð:ØM�CÝ+¨C°&©LÑ9Ô9Ð9ØÔ-°¸HÑ1DÑEˆMؘqÒ Ð ØG�Ý'¨¨sÔ/@ÀÑ/BÀFÐ.KÑ(KÑLÔLÐLð!õ�5‰zŒz˜SÔ.Ò.Ð.ØD�Ý'¨¨sÔ/@À&Ð.IÑ(IÑJÔJÐJؘ”8ð 6ØH�Ý'¨¨f© Ñ5Ô5Ð5ؘ”9ð 6ØI�Ý'¨¨f© Ñ5Ô5Ð5ݘ5‘z”zˆH؈H؈Mð JàˆFݘ8‘_”_ð 6ð 6�ؘ2‘ �ؘ#×+Ò+¨E°!¬HÑ5Ô5Ñ5��Ø �r˜MÑ)Ñ )ˆFݘH˜9 aÑ(Ô(ð 6ð 6�ؘ2‘ �ؘ#×+Ò+¨E°!¬HÑ5Ô5Ñ5��؈MøÝð Jð Jð JÝ#°#°#°#°v°vÐ$>Ñ?Ô?ÀTÐ Iøøøøð Jøøøs1à &C4Ã4 DÃ>DÄDËA7M Í M1ÍM,Í,M1cóÈ—|j |¦«std|z¦«‚t|¦«dkrd}t||z¦«‚t |d¦«S)a&Convert an IPv6 hextet string into an integer. Args: hextet_str: A string, the number to parse. Returns: The hextet as an integer. Raises: ValueError: if the input isn't strictly a hex number from [0..FFFF]. zOnly hex digits permitted in %rr$z$At most 4 characters permitted in %rr+)Ú _HEX_DIGITSÚ issupersetrr2r£)r�Ú hextet_strrˆs rrÓz_BaseV6._parse_hextetäsl€ð Œ×)Ò)¨*Ñ5Ô5ð MÝÐ>ÀÑKÑLÔLÐ Lõ ˆz‰?Œ?˜QÒ Ð Ø8ˆCݘS :Ñ-Ñ.Ô.Ð .å�:˜rÑ"Ô"Ð"r cóô—d}d}d}d}t|¦«D]'\}}|dkr|dz }|dkr|}||kr|}|}Œ#d}d}Œ(|dkr2||z}|t|¦«kr|dgz }dg|||…<|dkrdg|z}|S)aäCompresses a list of hextets. Compresses a list of strings, replacing the longest continuous sequence of "0" in the list with "" and adding empty strings at the beginning or at the end of the string such that subsequently calling ":".join(hextets) will produce the compressed version of the IPv6 address. Args: hextets: A list of strings, the hextets to compress. Returns: A list of strings. rdrrÜr6Ú)Ú enumerater2) r�ÚhextetsÚbest_doublecolon_startÚbest_doublecolon_lenÚdoublecolon_startÚdoublecolon_lenÚindexÚhextetÚbest_doublecolon_ends rÚ_compress_hextetsz_BaseV6._compress_hextetsþsæ€ð""$ÐØ ÐØÐØˆÝ& wÑ/Ô/ð 'ð '‰MˆE�6ؘŠ}ˆ}Ø 1Ñ$�Ø$¨Ò*Ð*à(-Ð%Ø"Ð%9Ò9Ð9à+:Ð(Ø->Ð*øà"#�Ø$&Ð!Ð!à  !Ò #Ð #Ø$:Ø$8ñ%9Ð ð$¥s¨7¡|¤|Ò3Ð3ؘB˜4‘�ØDFÀ4ˆGÐ*Ð+?Ð?Ñ @à%¨Ò*Ð*ؘ$ ™.�àˆr Ncóü‡—|€t|j¦«}||jkrtd¦«‚d|zŠˆfd„t ddd¦«D¦«}| |¦«}d |¦«S) a,Turns a 128-bit integer into hexadecimal notation. Args: ip_int: An integer, the IP address. Returns: A string, the hexadecimal representation of the address. Raises: ValueError: The address is bigger than 128 bits of all ones. NzIPv6 address is too largeú%032xc óL•—g|] }dt‰||dz…d¦«z‘Œ!S)rÐr$r+)r£©r>rÛÚhex_strs €rú z/_BaseV6._string_from_ip_int..Cs4ø€ÐKÐKÐK°a�4�#˜g a¨¨!© eœn¨bÑ1Ô1Ñ1ÐKÐKÐKr rrr$rÎ)r£r9rOrrôríro)r�r–råròs @rrÎz_BaseV6._string_from_ip_int.s…ø€ð ˆ>ݘœ‘\”\ˆFà �C”MÒ !Ð !ÝÐ8Ñ9Ô9Ð 9à˜FÑ"ˆØKÐKÐKÐK½5ÀÀBȹ?¼?ÐKÑKÔKˆà×'Ò'¨Ñ0Ô0ˆØ�xŠx˜Ñ Ô Ð r c󨇗t|t¦«rt|j¦«}n9t|t¦«rt|j¦«}nt|¦«}| |¦«}d|zŠˆfd„tddd¦«D¦«}t|ttf¦«rdd  |¦«|j fzSd  |¦«S)zmExpand a shortened IPv6 address. Returns: A string, the expanded IPv6 address. rïcó*•—g|]}‰||dz…‘ŒS)r$r rñs €rróz8_BaseV6._explode_shorthand_ip_string..Xs%ø€Ð9Ð9Ð9 A�˜˜1˜Q™3˜”Ð9Ð9Ð9r rrr$rñrÎ) rJrr0rhr!r>r§rôrprorf)r{r¨r–rÖròs @rryz$_BaseV6._explode_shorthand_ip_stringHsÙø€õ �d�KÑ (Ô (ð ݘÔ-Ñ.Ô.ˆFˆFÝ ˜�mÑ ,Ô ,ð ݘœ‘\”\ˆFˆF嘑Y”YˆFà×)Ò)¨&Ñ1Ô1ˆØ˜FÑ"ˆØ9Ð9Ð9Ð9­¨q°"°a©¬Ð9Ñ9Ô9ˆÝ �d�\­=Ð9Ñ :Ô :ð @ؘcŸhšh u™oœo¨t¬Ð?Ñ?Ð ?Ø�xŠx˜‰ŒÐr cóz—|jddd… dd¦«}d |¦«dzS)z�Return the reverse DNS pointer name for the IPv6 address. This implements the method described in RFC3596 2.5. NrdrÎrãraú .ip6.arpa)r|Úreplacero)r{Ú reverse_charss rr�z_BaseV6._reverse_pointer]s=€ð œ  d d¨ dÔ+×3Ò3°C¸Ñ<Ô<ˆ Ø�xŠx˜ Ñ&Ô&¨Ñ4Ð4r cóv—| d¦«\}}}|sd}n|rd|vrtd|z¦«‚||fS)zÝHelper function to parse IPv6 string address with scope id. See RFC 4007 for details. Args: ip_str: A string, the IPv6 address. Returns: (addr, scope_id) tuple. ú%NzInvalid IPv6 address: "%r")Ú partitionr)r¨r3ÚsepÚscope_ids rÚ_split_scope_idz_BaseV6._split_scope_idfs]€ð%×.Ò.¨sÑ3Ô3шˆc�8Øð K؈HˆHØð K˜S H˜_˜_Ý#Ð$@À6Ñ$IÑJÔJÐ JØ�Xˆ~Ðr có—|jSr¯rsrzs rrtz_BaseV6.max_prefixlenzrur có—|jSr¯rÕrzs rrMz_BaseV6.version~rwr r¯)rr r r r³reÚ IPV6LENGTHrOrÒÚ frozensetrßrNr[rµr^r§rÓrírÎryr�rSrÿr´rtrMr r rrÇrÇKsZ€€€€€ððð€IØ€HØ�J‘ !Ñ#€IØ€MØ�)Ð4Ñ5Ô5€KØ€Nð€Nàð'ð'ñ„[ð'ð&ðnJðnJñ„[ðnJð`ð#ð#ñ„[ð#ð2ð-ð-ñ„[ð-ð^ð!ð!ð!ñ„[ð!ð2ððð*5ð5ð5ðððñ„\ðð&ð#ð#ñ„Xð#ðððñ„Xðððr rÇc󤇗eZdZdZdZd„Zˆfd„Zˆfd„Zd„Zˆfd„Z d„Z ˆfd „Z d „Z e d „¦«Ze d „¦«Ze d „¦«Ze d„¦«Ze d„¦«Ze d„¦«Ze ej¦«d„¦«¦«Ze d„¦«Ze d„¦«Ze d„¦«Ze d„¦«Ze d„¦«Ze d„¦«ZˆxZS)rz/Represent and manipulate single IPv6 Addresses.)r9Ú _scope_idrzcóÚ—t|t¦«r%| |¦«||_d|_dSt|t ¦«r?| |d¦«t |d¦«|_d|_dSt|¦«}d|vrtd|›�¦«‚|  |¦«\}|_|  |¦«|_dS)aInstantiate a new IPv6 address object. Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv6Address('2001:db8::') == IPv6Address(42540766411282592856903984951653826560) or, more generally IPv6Address(int(IPv6Address('2001:db8::'))) == IPv6Address('2001:db8::') Raises: AddressValueError: If address isn't a valid IPv6 address. Nr+r•r.r|) rJr£rŠr9rr«rŽrcr0rrÿr§r}s rrzIPv6Address.__init__‰sè€õ$ �g�sÑ #Ô #ð Ø × #Ò # GÑ ,Ô ,Ð ,؈DŒHØ!ˆDŒNØ ˆFõ �g�uÑ %Ô %ð Ø × &Ò & w°Ñ 3Ô 3Ð 3Ý—~’~ g¨uÑ5Ô5ˆDŒHØ!ˆDŒNØ ˆFõ�w‘<”<ˆØ �(ˆ?ˆ?Ý#Ð$D¸Ð$DÐ$DÑEÔEÐ EØ#'×#7Ò#7¸Ñ#AÔ#AÑ ˆ�$”.à×+Ò+¨HÑ5Ô5ˆŒˆˆr có¶•—|j}|€ t¦« ¦«Sd}t¦« ¦«}|d|…›|›�S)Né)Ú ipv4_mappedrâry)r{r Ú prefix_lenÚraw_exploded_strr±s €rryz(IPv6Address._explode_shorthand_ip_string±s\ø€ØÔ&ˆ Ø Ð Ý‘7”7×7Ò7Ñ9Ô9Ð 9؈ Ý ™7œ7×?Ò?ÑAÔAÐØ" ; J ;Ô/Ð@°Ð@Ð@Ð@r có0•—|j}|€ t¦« ¦«Sd}t¦« ¦«d|…}|j}|›|d›�ddd… dd¦«}d |¦«dzS)NrÚ008xrdrÎrãrar÷)r râr�ryr9røro)r{r r r rØrùr±s €rr�zIPv6Address._reverse_pointer¹s˜ø€ØÔ&ˆ Ø Ð Ý‘7”7×+Ò+Ñ-Ô-Ð -؈ Ý ™7œ7×?Ò?ÑAÔAÀ+À:À+ÔNÐà”?ˆØ+Ð<¨XÐ<Ð<Ð<¸T¸T¸r¸TÔB×JÒJÈ3ÐPRÑSÔSˆ Ø�xŠx˜ Ñ&Ô&¨Ñ4Ð4r có´—|j}|€tdt|¦«z¦«‚|jdz }| |¦«›dt|¦«›�S)aÕReturn convenient text representation of IPv4-mapped IPv6 address See RFC 4291 2.5.5.2, 2.2 p.3 for details. Returns: A string, 'x:x:x:x:x:x:d.d.d.d', where the 'x's are the hexadecimal values of the six high-order 16-bit pieces of the address, and the 'd's are the decimal values of the four low-order 8-bit pieces of the address (standard IPv4 representation) as defined in RFC 4291 2.2 p.3. Nz0Can not apply to non-IPv4-mapped IPv6 address %srrÎ)r rr0r9rÎ)r{r Úhigh_order_bitss rÚ_ipv4_mapped_ipv6_to_strz$IPv6Address._ipv4_mapped_ipv6_to_strÄse€ðÔ&ˆ Ø Ð Ý#Ð$VÕY\Ð]aÑYbÔYbÑ$bÑcÔcÐ cØœ( b™.ˆØ×2Ò2°?ÑCÔCÐCÐCÅSÈÑEUÔEUÐEUÐVÐVr c󬕗|j}|€!t¦« ¦«}n| ¦«}|jr |dz|jzn|S)Nrû)r rârÏrr)r{r r¨r±s €rrÏzIPv6Address.__str__ÖsTø€ØÔ&ˆ Ø Ð Ý‘W”W—_’_Ñ&Ô&ˆFˆFà×2Ò2Ñ4Ô4ˆFØ04´ÐJˆv˜‰|˜dœnÑ,Ð,ÀFÐJr có8—t|j|jf¦«Sr¯)rÑr9rrzs rrÓzIPv6Address.__hash__Þs€Ý�T”X˜tœ~Ð.Ñ/Ô/Ð/r c󢕗t¦« |¦«}|turtS|sdS|jt |dd¦«kS)NFr)râr¼rsrÚgetattr)r{r»r¦r±s €rr¼zIPv6Address.__eq__ásOø€Ý™œŸš uÑ-Ô-ˆ Ø �NÐ *Ð *Ý!Ð !Øð Ø�5ØŒ~¥¨° ¸TÑ!BÔ!BÒBÐBr có0—|jt|¦«ffSr¯r°rzs rr²zIPv6Address.__reduce__és€Ø”¥ T¡¤  Ð-Ð-r có—|jS)zÈIdentifier of a particular zone of the address's scope. See RFC 4007 for details. Returns: A string identifying the zone of the address if specified, else None. )rrzs rrþzIPv6Address.scope_idìs €ðŒ~Ðr có*—t|j¦«Sr�)r,r9rzs rr‚zIPv6Address.packedørƒr có>—|j}|�|jS||jjvSr,)r r-rDr‘©r{r s rr-zIPv6Address.is_multicastýs+€ðÔ&ˆ Ø Ð "ØÔ+Ð +Ø�t”Ô9Ð9Ð9r cón‡—‰j}|�|jStˆfd„‰jjD¦«¦«S)r6Nc3ó •K—|]}‰|vV—Œ dSr¯r )r>rÛr{s €rr@z*IPv6Address.is_reserved..s'øèè€ÐIÐI �4˜1�9ÐIÐIÐIÐIÐIÐIr )r r7rCrDÚ_reserved_networksrs` rr7zIPv6Address.is_reserved sDø€ðÔ&ˆ Ø Ð "ØÔ*Ð *ÝÐIÐIÐIÐI d¤oÔ&HÐIÑIÔIÑIÔIÐIr có>—|j}|�|jS||jjvSr:)r r;rDr—rs rr;zIPv6Address.is_link_locals+€ðÔ&ˆ Ø Ð "ØÔ,Ð ,Ø�t”Ô9Ð9Ð9r có—||jjvS©a`Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )rDÚ_sitelocal_networkrzs rÚ is_site_localzIPv6Address.is_site_local&s€ð�t”Ô9Ð9Ð9r c󸇗‰j}|�|jStˆfd„‰jjD¦«¦«o$t ˆfd„‰jjD¦«¦«S)r‡Nc3ó •K—|]}‰|vV—Œ dSr¯r r‰s €rr@z)IPv6Address.is_private..IrŠr c3ó •K—|]}‰|vV—Œ dSr¯r r‰s €rr@z)IPv6Address.is_private..JrŒr )r rHrCrDrErFrGrs` rrHzIPv6Address.is_private4sqø€ð"Ô&ˆ Ø Ð "ØÔ)Ð )å ÐIÐIÐIÐI t¤Ô'HÐIÑIÔIÑ IÔ Ið ]ÝÐ\Ð\Ð\Ð\¨t¬Ô/[Ð\Ñ\Ô\Ñ\Ô\ð r có2—|j}|�|jS|j SrŽ)r rJrHrs rrJzIPv6Address.is_globalMs&€ðÔ&ˆ Ø Ð "ØÔ(Ð (Ø”?Ð"Ð"r có8—|j}|�|jS|jdkS)rLNr)r rMr9rs rrMzIPv6Address.is_unspecifiedas'€ðÔ&ˆ Ø Ð "ØÔ-Ð -ØŒx˜1Š}Ðr có8—|j}|�|jS|jdkS)rONr6)r rPr9rs rrPzIPv6Address.is_loopbackos'€ðÔ&ˆ Ø Ð "ØÔ*Ð *ØŒx˜1Š}Ðr cóP—|jdz dkrdSt|jdz¦«S)z¶Return the IPv4 mapped address. Returns: If the IPv6 address is a v4 mapped address, return the IPv4 mapped address. Return None otherwise. rrÑNìÿÿ©r9rrzs rr zIPv6Address.ipv4_mapped}s/€ð ŒH˜‰N˜vÒ %Ð %Ø�4ݘ4œ8 jÑ0Ñ1Ô1Ð1r có†—|jdz dkrdSt|jdz dz¦«t|jdz¦«fS)zÛTuple of embedded teredo IPs. Returns: Tuple of the (server, client) IPs or None if the address doesn't appear to be a teredo address (doesn't start with 2001::/32) é`i Né@r)r*rzs rÚteredozIPv6Address.teredoŠsN€ð ŒH˜‰N˜zÒ )Ð )Ø�4ݘTœX¨™^¨zÑ9Ñ:Ô:ݘTœX˜I¨ Ñ2Ñ3Ô3ð5ð 5r cóV—|jdz dkrdSt|jdz dz¦«S)zÎReturn the IPv4 6to4 embedded address. Returns: The IPv4 6to4-embedded address if present or None if the address doesn't appear to contain a 6to4 embedded address. épi NéPr)r*rzs rÚ sixtofourzIPv6Address.sixtofour™s3€ð ŒH˜‰O Ò &Ð &Ø�4ݘDœH¨™N¨jÑ8Ñ9Ô9Ð9r )rr r r r³rryr�rrÏrÓr¼r²r´rþr‚r-r7r;r!rQr˜rHrJrMrPr r.r2rërìs@rrrƒsUø€€€€€à9Ð9à3€Ið&6ð&6ð&6ðPAðAðAðAðAð 5ð 5ð 5ð 5ð 5ðWðWðWð$KðKðKðKðKð0ð0ð0ðCðCðCðCðCð.ð.ð.ðð ð ñ„Xð ðð*ð*ñ„Xð*ðð :ð :ñ„Xð :ðð Jð Jñ„Xð Jðð :ð :ñ„Xð :ðð :ð :ñ„Xð :ðØ€YÔÑÔð ð ñÔñ„Xð ð.ð#ð#ñ„Xð#ð&ð ð ñ„Xð ðð ð ñ„Xð ðð 2ð 2ñ„Xð 2ðð 5ð 5ñ„Xð 5ðð :ð :ñ„Xð :ð :ð :ð :ð :r rcó쇗eZdZd„Zejd„¦«Zˆfd„Zd„Zd„Z d„Z e j Z e d„¦«Ze d„¦«Ze d „¦«Ze d „¦«Ze d „¦«Ze ˆfd „¦«ZˆxZS) r!cóà—| |¦«\}}t ||¦«t||fd¬¦«|_|jj|_|jj|_dSr›)r­rrrr÷rrfrœs rrzIPv6Interface.__init__©ržr có—|jjSr¯r rzs rr zIPv6Interface.hostmask±r¡r cóX•—dt¦« ¦«|jfzSrð)rârÏrf©r{r±s €rrÏzIPv6Interface.__str__µs*ø€Ø�%™'œ'Ÿ/š/Ñ+Ô+Øœ/ð+ñ+ð +r có–—t ||¦«}|tus|s|S |j|jkS#t$rYdSwxYwr)rr¼rsr÷rgr¥s rr¼zIPv6Interface.__eq__¹r§r¨có¶—t ||¦«}|tur|S |j|jkp|j|jko|S#t$rYdSwxYwr)rr¿rsr÷rgrªs rr¿zIPv6Interface.__lt__Åsz€Ý"×)Ò)¨$°Ñ6Ô6ˆ Ø �>Ð )Ð )ØÐ ð Ø”L 5¤=Ò0ðCØ”L E¤MÒ1ÐB°lð Døåð ð ð ð�5�5ð øøøs¨!A Á AÁAcóh—t|j|jt|jj¦«f¦«Sr¯r­rzs rrÓzIPv6Interface.__hash__Ñr®r có*—t|j¦«Sr¯)rr9rzs rr>zIPv6Interface.ipÖr°r cóJ—| |j¦«›d|j›�Srr£rzs rr zIPv6Interface.with_prefixlenÚr²r cóJ—| |j¦«›d|j›�Srr´rzs rrzIPv6Interface.with_netmaskßrµr cóJ—| |j¦«›d|j›�Srr·rzs rrzIPv6Interface.with_hostmaskär¸r có0—|jdko |jjS)Nr)r9r÷rMrzs rrMzIPv6Interface.is_unspecifiedés€àŒx˜1Š}Ð< ¤Ô!<Ðr rrrMrPrërìs@rr!r!§sSø€€€€€ð2ð2ð2ðÔð%ð%ñÔð%ð+ð+ð+ð+ð+ð ð ð ð ð ð ðTðTðTð Ô*€Jà ð%ð%ñ„Xð%ðð+ð+ñ„Xð+ðð(ð(ñ„Xð(ðð)ð)ñ„Xð)ðð=ð=ñ„Xð=ðð@ð@ð@ð@ñ„Xð@ð@ð@ð@ð@r r!có:—eZdZdZeZdd„Zd„Zed„¦«Z dS)ravThis class represents and manipulates 128-bit IPv6 networks. Attributes: [examples for IPv6('2001:db8::1000/124')] .network_address: IPv6Address('2001:db8::1000') .hostmask: IPv6Address('::f') .broadcast_address: IPv6Address('2001:db8::100f') .netmask: IPv6Address('ffff:ffff:ffff:ffff:ffff:ffff:ffff:fff0') .prefixlen: 124 Tcóö‡—| |¦«\Š}t‰¦«|_| |¦«\|_|_t |j¦«}|t |j¦«z|kr=|rtd|z¦«‚t|t |j¦«z¦«|_|j|jdz kr|j |_ dS|j|jkr ˆfd„|_ dSdS)aæInstantiate a new IPv6 Network object. Args: address: A string or integer representing the IPv6 network or the IP and prefix/netmask. '2001:db8::/128' '2001:db8:0000:0000:0000:0000:0000:0000/128' '2001:db8::' are all functionally the same in IPv6. That is to say, failing to provide a subnetmask will create an object with a mask of /128. Additionally, an integer can be passed, so IPv6Network('2001:db8::') == IPv6Network(42540766411282592856903984951653826560) or, more generally IPv6Network(int(IPv6Network('2001:db8::'))) == IPv6Network('2001:db8::') strict: A boolean. If true, ensure that we have been passed A true network address, eg, 2001:db8::1000/124 and not an IP address on a network, eg, 2001:db8::1/124. Raises: AddressValueError: If address isn't a valid IPv6 address. NetmaskValueError: If the netmask isn't valid for an IPv6 address. ValueError: If strict was True and a network address was not supplied. r»r6có$•—t‰¦«gSr¯)rr½s€rr¾z&IPv6Network.__init__..0 r¿r N) r­rrhr^rrfr£rrNrûrùrÀs @rrzIPv6Network.__init__ sø€ð>×,Ò,¨WÑ5Ô5‰ ˆˆdå*¨4Ñ0Ô0ˆÔØ(,×(:Ò(:¸4Ñ(@Ô(@Ñ%ˆŒ �d”oÝ�TÔ)Ñ*Ô*ˆØ •C˜œ Ñ%Ô%Ñ %¨Ò /Ð /Øð FÝ Ð!7¸$Ñ!>Ñ?Ô?Ð?å'2°6Ý36°t´|Ñ3DÔ3Dñ4Eñ(Fô(F�Ô$ð Œ?˜tÔ2°QÑ6Ò 7Ð 7ØœˆDŒJˆJˆJØ Œ_ Ô 3Ò 3Ð 3Ø4Ð4Ð4Ð4ˆDŒJˆJˆJð4Ð 3r c#óºK—t|j¦«}t|j¦«}t|dz|dz¦«D]}| |¦«V—ŒdS)z¢Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the Subnet-Router anycast address. r6Nrórös rrùzIPv6Network.hosts2 spèè€õ�dÔ*Ñ+Ô+ˆÝ˜Ô.Ñ/Ô/ˆ Ý�w ‘{ I°¡MÑ2Ô2ð )ð )ˆAØ×%Ò% aÑ(Ô(Ð (Ð (Ð (Ð (ð )ð )r có2—|jjo |jjSr)rhr!r^rzs rr!zIPv6Network.is_site_local> s €ðÔ$Ô2ð5ØÔ&Ô4ð 6r NrÃ) rr r r rrõrrùr´r!r r rrròsd€€€€€ð ð ð!€Nð.5ð.5ð.5ð.5ð` )ð )ð )ðð 6ð 6ñ„Xð 6ð 6ð 6r rcóÜ—eZdZed¦«Zed¦«Zed¦«ed¦«ed¦«ed¦«ed¦«ed¦«ed ¦«ed ¦«ed ¦«ed ¦«ed¦«g Zed ¦«ed¦«ed¦«ed¦«ed¦«ed¦«gZed¦«ed¦«ed¦«ed¦«ed¦«ed¦«ed¦«ed¦«ed¦«ed¦«ed¦«ed¦«ed¦«ed ¦«ed!¦«gZed"¦«Z d#S)$Ú_IPv6Constantsz fe80::/10zff00::/8z::1/128z::/128z ::ffff:0:0/96z64:ff9b:1::/48z100::/64z 2001::/23z 2001:db8::/32z 2002::/16z 3fff::/20zfc00::/7z 2001:1::1/128z 2001:1::2/128z 2001:3::/32z2001:4:112::/48z 2001:20::/28z 2001:30::/28z::/8z100::/8z200::/7z400::/6z800::/5z1000::/4z4000::/3z6000::/3z8000::/3zA000::/3zC000::/3zE000::/4zF000::/5zF800::/6zFE00::/9z fec0::/10N) rr r rr—r‘rErGrr r r rrGrGN sû€€€€€à$˜ [Ñ1Ô1Ðà$˜ ZÑ0Ô0Ðð ˆ �IÑÔØˆ �HÑÔØˆ �OÑ$Ô$؈ Ð$Ñ%Ô%؈ �JÑÔØˆ �KÑ Ô Øˆ �OÑ$Ô$àˆ �KÑ Ô àˆ �KÑ Ô Øˆ �JÑÔØˆ �KÑ Ô ð Ðð" ˆ �OÑ$Ô$؈ �OÑ$Ô$؈ �MÑ"Ô"؈ Ð%Ñ&Ô&؈ �NÑ#Ô#؈ �NÑ#Ô#ð $Ð ð ˆ �FÑÔ˜[˜[¨Ñ3Ô3؈ �IÑÔ    ¨IÑ 6Ô 6؈ �IÑÔ    ¨JÑ 7Ô 7؈ �JÑÔ  ¨ZÑ!8Ô!8؈ �JÑÔ  ¨ZÑ!8Ô!8؈ �JÑÔ  ¨ZÑ!8Ô!8؈ �JÑÔ  ¨ZÑ!8Ô!8؈ �JÑÔð Ðð%˜ [Ñ1Ô1ÐÐÐr rGrÃ)%r Ú __version__rQrxrrrrrrr"r(r,r4r?rErUrbrnrurwrÞÚtotal_orderingrKrprUrDrWrr rrÅrÇrr!rrGr r rúrJseðððð€ ðÐÐÐà € Ø € ð0ð0ð0ð0ð0˜ ñ0ô0ð0ð0ð0ð0ð0ð0˜ ñ0ô0ð0ðSðSðSð:SðSðSðSð:UðUðUðDCðCðCð( Cð Cð Cð ðððððð( :ð :ð :ð 4ð4ð4ðn.ð.ð.ðb36ð36ð36ðlððð2o,ðo,ðo,ðo,ðo,ño,ôo,ðo,ðd€à ÔðhNðhNðhNðhNðhN�>ñhNôhNñÔðhNðV ÔðH4ðH4ðH4ðH4ðH4�>ñH4ôH4ñÔðH4ðVððððñôðð )€ ÔðJðJðJðJðJñJôJðJðZI:ðI:ðI:ðI:ðI:�'˜<ñI:ôI:ðI:ðX@)ð@)ð@)ð@)ð@)�Kñ@)ô@)ð@)ðFO%ðO%ðO%ðO%ðO%�'˜<ñO%ôO%ðO%ðd#2ð#2ð#2ð#2ð#2ñ#2ô#2ð#2ðL(€ ÔØ'€ Ôðuðuðuðuðuñuôuðuðp a:ða:ða:ða:ða:�'˜<ña:ôa:ða:ðH H@ðH@ðH@ðH@ðH@�KñH@ôH@ðH@ðVY6ðY6ðY6ðY6ðY6�'˜<ñY6ôY6ðY6ðx,2ð,2ð,2ð,2ð,2ñ,2ô,2ð,2ð^(€ ÔØ'€ ÔÐÐr