grthtrhthjhtyjytjytkergtrhtrjytjerhrfh4:24 29/09/2026U iÛf¢‡ã@s^dZddlZddlZddlZddlZddlZddlZddlZddlZddl Z ddl m Z ddl m Z mZddddd gZejdZd ZGd d „d ƒZeƒad ZdZdZd%dd„ZGdd„dejƒZGdd„dejƒZGdd„deƒZGdd„deƒZGdd „d eƒZGdd„dƒZ dd„Z!e"dk�rZe!ƒZ#e#j$Z$de$k�rpe$ %d¡Z&e'e$de&…e(ƒe)ƒdgƒZ*e$e&dd…Z$nddl+Z*e,e*e$ƒZ-e-e#j.e#j/fe#j0e#j1fe#j2e#j3d�Z4e#j5�r6z ddl6Z6Wn.e7k �rèe8d ej9d!�e :d¡YnXe6 ;d"¡d#Z¡Wne?k �rXYnXdS)&a­An RFC 5321 smtp proxy with optional RFC 1870 and RFC 6531 extensions. Usage: %(program)s [options] [localhost:localport [remotehost:remoteport]] Options: --nosetuid -n This program generally tries to setuid `nobody', unless this flag is set. The setuid call will fail if this program is not run as root (in which case, use this flag). --version -V Print the version number and exit. --class classname -c classname Use `classname' as the concrete SMTP proxy class. Uses `PureProxy' by default. --size limit -s limit Restrict the total size of the incoming message to "limit" number of bytes via the RFC 1870 SIZE extension. Defaults to 33554432 bytes. --smtputf8 -u Enable the SMTPUTF8 extension and behave as an RFC 6531 smtp proxy. --debug -d Turn on debugging prints. --help -h Print this message and exit. Version: %(__version__)s If localhost is not given then `localhost' is used, and if localport is not given then 8025 is used. If remotehost is not given then `localhost' is used, and if remoteport is not given, then 25 is used. éN)Úwarn)Ú get_addr_specÚget_angle_addrÚ SMTPChannelÚ SMTPServerÚDebuggingServerÚ PureProxyÚ MailmanProxyzPython SMTP proxy version 0.3c@seZdZdd„Zdd„ZdS)ÚDevnullcCsdS©N©©ÚselfÚmsgr r ú*/opt/alt/python38/lib64/python3.8/smtpd.pyÚwritefóz Devnull.writecCsdSr r ©rr r rÚflushgrz Devnull.flushN)Ú__name__Ú __module__Ú __qualname__rrr r r rr esr Ú z, iÚcCs4tttƒtjd�|r&t|tjd�t |¡dS)N©Úfile)ÚprintÚ__doc__ÚglobalsÚsysÚstderrÚexit)Úcoderr r rÚusagepsr#c@sþeZdZdZdZdZe efdd„¡Ze dd„ƒZ e dd d fd d „Z d d „Z dd„Ze dd„ƒZejdd„ƒZe dd„ƒZejdd„ƒZe dd„ƒZejdd„ƒZe dd„ƒZejdd„ƒZe dd„ƒZejdd„ƒZe dd „ƒZejd!d „ƒZe d"d#„ƒZejd$d#„ƒZe d%d&„ƒZejd'd&„ƒZe d(d)„ƒZejd*d)„ƒZe d+d,„ƒZejd-d,„ƒZe d.d/„ƒZejd0d/„ƒZd1d2„Zd3d4„Zd5d6„Zd7d8„Zd9d:„Zd;d<„Z d=d>„Z!d?d@„Z"dAdB„Z#dCdD„Z$dEdF„Z%dGdH„Z&dIdJ„Z'dKdL„Z(dMdN„Z)dOdP„Z*dQdR„Z+dS)SrréicCs|Sr r )Úxr r rÚ|rzSMTPChannel.cCs0zt|j ¡ƒWStk r*|jYSXdSr )ÚmaxÚcommand_size_limitsÚvaluesÚ ValueErrorÚcommand_size_limitrr r rÚmax_command_size_limit~sz"SMTPChannel.max_command_size_limitNFc Cs&tjj|||d�||_||_||_||_||_||_|rF|rFt dƒ‚|rdd|_ d|_ d|_ t |_nd|_ d|_ tdƒ|_ d |_| ¡d|_d |_|j ¡t ¡|_z| ¡|_WnBtk rø}z$| ¡|jd tjkrâ‚WY¢dSd}~XYnXtd t |jƒt!d �| "d|jt#f¡dS)N©ÚmapúFdecode_data and enable_SMTPUTF8 cannot be set to True at the same timerú Ú.ró ó.ó FrzPeer:rz 220 %s %s)$ÚasynchatÚ async_chatÚ__init__Ú smtp_serverÚconnÚaddrÚdata_size_limitÚenable_SMTPUTF8Ú _decode_datar*Ú _emptystringÚ_linesepÚ_dotsepÚNEWLINEÚ_newlineÚordÚ_set_rset_stateÚ seen_greetingÚ extended_smtpr(ÚclearÚsocketZgetfqdnÚfqdnZ getpeernameÚpeerÚOSErrorÚcloseÚargsÚerrnoZENOTCONNrÚreprÚ DEBUGSTREAMÚpushÚ __version__) rZserverr9r:r;r.r<Ú decode_dataÚerrr r rr7…s@   zSMTPChannel.__init__cCs.|j|_d|_g|_d|_d|_| d¡dS)z/Reset state variables to their post-DATA state.NFrr2)ÚCOMMANDÚ smtp_stateÚmailfromÚrcpttosÚrequire_SMTPUTF8Ú num_bytesÚset_terminatorrr r rÚ_set_post_data_state¬s z SMTPChannel._set_post_data_statecCs| ¡d|_g|_dS)z.Reset all state variables except the greeting.rN)r\Ú received_dataÚreceived_linesrr r rrDµszSMTPChannel._set_rset_statecCstdtdƒ|jS)NzTAccess to __server attribute on SMTPChannel is deprecated, use 'smtp_server' insteadé©rÚDeprecationWarningr8rr r rÚ__server½s ÿzSMTPChannel.__servercCstdtdƒ||_dS)NzRSetting __server attribute on SMTPChannel is deprecated, set 'smtp_server' insteadr_r`©rÚvaluer r rrbÂs ÿcCstdtdƒ|jS)NzUAccess to __line attribute on SMTPChannel is deprecated, use 'received_lines' insteadr_©rrar^rr r rÚ__lineÈs ÿzSMTPChannel.__linecCstdtdƒ||_dS)NzSSetting __line attribute on SMTPChannel is deprecated, set 'received_lines' insteadr_rercr r rrfÍs ÿcCstdtdƒ|jS)NzRAccess to __state attribute on SMTPChannel is deprecated, use 'smtp_state' insteadr_©rrarVrr r rÚ__stateÓs ÿzSMTPChannel.__statecCstdtdƒ||_dS)NzPSetting __state attribute on SMTPChannel is deprecated, set 'smtp_state' insteadr_rgrcr r rrhØs ÿcCstdtdƒ|jS)NzXAccess to __greeting attribute on SMTPChannel is deprecated, use 'seen_greeting' insteadr_©rrarErr r rÚ __greetingÞs ÿzSMTPChannel.__greetingcCstdtdƒ||_dS)NzVSetting __greeting attribute on SMTPChannel is deprecated, set 'seen_greeting' insteadr_rircr r rrjãs ÿcCstdtdƒ|jS)NzSAccess to __mailfrom attribute on SMTPChannel is deprecated, use 'mailfrom' insteadr_©rrarWrr r rÚ __mailfromés ÿzSMTPChannel.__mailfromcCstdtdƒ||_dS)NzQSetting __mailfrom attribute on SMTPChannel is deprecated, set 'mailfrom' insteadr_rkrcr r rrlîs ÿcCstdtdƒ|jS)NzQAccess to __rcpttos attribute on SMTPChannel is deprecated, use 'rcpttos' insteadr_©rrarXrr r rÚ __rcpttosôs ÿzSMTPChannel.__rcpttoscCstdtdƒ||_dS)NzOSetting __rcpttos attribute on SMTPChannel is deprecated, set 'rcpttos' insteadr_rmrcr r rrnùs ÿcCstdtdƒ|jS)NzTAccess to __data attribute on SMTPChannel is deprecated, use 'received_data' insteadr_©rrar]rr r rÚ__dataÿs ÿzSMTPChannel.__datacCstdtdƒ||_dS)NzRSetting __data attribute on SMTPChannel is deprecated, set 'received_data' insteadr_rorcr r rrps ÿcCstdtdƒ|jS)NzKAccess to __fqdn attribute on SMTPChannel is deprecated, use 'fqdn' insteadr_©rrarIrr r rÚ__fqdn s ÿzSMTPChannel.__fqdncCstdtdƒ||_dS)NzISetting __fqdn attribute on SMTPChannel is deprecated, set 'fqdn' insteadr_rqrcr r rrrs ÿcCstdtdƒ|jS)NzKAccess to __peer attribute on SMTPChannel is deprecated, use 'peer' insteadr_©rrarJrr r rÚ__peers ÿzSMTPChannel.__peercCstdtdƒ||_dS)NzISetting __peer attribute on SMTPChannel is deprecated, set 'peer' insteadr_rsrcr r rrts ÿcCstdtdƒ|jS)NzKAccess to __conn attribute on SMTPChannel is deprecated, use 'conn' insteadr_©rrar9rr r rÚ__conn s ÿzSMTPChannel.__conncCstdtdƒ||_dS)NzISetting __conn attribute on SMTPChannel is deprecated, set 'conn' insteadr_rurcr r rrv%s ÿcCstdtdƒ|jS)NzKAccess to __addr attribute on SMTPChannel is deprecated, use 'addr' insteadr_©rrar:rr r rÚ__addr+s ÿzSMTPChannel.__addrcCstdtdƒ||_dS)NzISetting __addr attribute on SMTPChannel is deprecated, set 'addr' insteadr_rwrcr r rrx0s ÿcCs&tj |t|d|jrdndƒ¡dS)Nr0úutf-8Úascii)r5r6rQÚbytesrYr r r rrQ7s  ÿzSMTPChannel.pushcCs|d}|j|jkr|j}n|j|jkr*|j}|r<|j|krÚjoinr^rrOrPrVrUrZrQr=rÚfindÚupperÚstriprFr(r+Úgetattrr|r;Úsplitr?r@r~rBr]rJrWrXr„r…r8Úprocess_messager\) rÚlineZszÚiÚcommandÚargZmax_szÚmethodr€ÚtextrMÚkwargsZstatusr r rÚfound_terminatorLsl   ÿ ÿ   þ zSMTPChannel.found_terminatorcCsH|s| d¡dS|jr&| d¡dS| ¡||_| d|j¡dS)Nz501 Syntax: HELO hostnameú503 Duplicate HELO/EHLOz250 %s)rQrErDrI©rr‘r r rÚ smtp_HELOŠs  zSMTPChannel.smtp_HELOcCs²|s| d¡dS|jr&| d¡dS| ¡||_d|_| d|j¡|jrr| d|j¡|jdd7<|js‚| d¡|jr¤| d ¡|jdd 7<| d ¡dS) Nz501 Syntax: EHLO hostnamer–Tz250-%sz 250-SIZE %sÚMAILéz 250-8BITMIMEz 250-SMTPUTF8é z250 HELP) rQrErDrFrIr;r(r=r<r—r r rÚ smtp_EHLO–s&    zSMTPChannel.smtp_EHLOcCs|r| d¡n | d¡dS)Nz501 Syntax: NOOPr†©rQr—r r rÚ smtp_NOOP¬s zSMTPChannel.smtp_NOOPcCs| d¡| ¡dS)Nz221 Bye)rQZclose_when_doner—r r rÚ smtp_QUIT²s zSMTPChannel.smtp_QUITcCs0t|ƒ}|d|… ¡|kr,||d… ¡SdS)Nr)r}r‰rŠ)rÚkeywordr‘Zkeylenr r rÚ_strip_command_keyword·sz"SMTPChannel._strip_command_keywordcCsF|sdS| ¡ d¡r$t|ƒ\}}n t|ƒ\}}|s<||fS|j|fS)N)rrú<)ÚlstripÚ startswithrrZ addr_spec)rr‘ÚaddressÚrestr r rÚ_getaddr½s zSMTPChannel._getaddrcCsHi}|D]:}| d¡\}}}| ¡r,|r2|s2dS|r:|nd||<q|S)Nú=T)Ú partitionÚisalnum)rÚparamsÚresultZparamÚeqrdr r rÚ _getparamsÈszSMTPChannel._getparamscCs|rôd}| ¡}|dkr$| d¡qþ|dkr8| d¡qþ|dkr^d}|jrR||7}| |¡qþ|dkr„d }|jrx||7}| |¡qþ|d kr˜| d ¡qþ|d kr¬| d ¡qþ|dkrÀ| d¡qþ|dkrÔ| d¡qþ|dkrè| d¡qþ| d¡n | d¡dS)Nú [SP ]ZEHLOz250 Syntax: EHLO hostnameZHELOz250 Syntax: HELO hostnamer™z 250 Syntax: MAIL FROM:
ZRCPTz250 Syntax: RCPT TO:
r|z250 Syntax: DATAZRSETz250 Syntax: RSETZNOOPz250 Syntax: NOOPZQUITz250 Syntax: QUITZVRFYz250 Syntax: VRFY
zD501 Supported commands: EHLO HELO MAIL RCPT DATA RSET NOOP QUIT VRFYzD250 Supported commands: EHLO HELO MAIL RCPT DATA RSET NOOP QUIT VRFY)r‰rQrF)rr‘ZextendedZlc_argrr r rÚ smtp_HELPÓs:          zSMTPChannel.smtp_HELPcCs@|r2| |¡\}}|r"| d¡q<| d|¡n | d¡dS)NzB252 Cannot VRFY user, but will accept message and attempt deliveryz502 Could not VRFY %sz501 Syntax: VRFY
)r§rQ)rr‘r¥r«r r rÚ smtp_VRFYös  zSMTPChannel.smtp_VRFYcCsÌ|js| d¡dStd|td�d}|jr4|d7}|dkrJ| |¡dS| d|¡}| |¡\}}|sv| |¡dS|jsŽ|rŽ| |¡dS|jr¢| d¡dS| ¡  ¡|_ |  |j ¡}|dkrÒ| |¡dS|j sú|  dd ¡}|d krú| d ¡dS|j�r8|  d d ¡}|dk�r d|_n|d k �r8| d¡dS|  dd¡}|�rˆ| ¡�sb| |¡dS|j�rˆt|ƒ|jk�rˆ| d¡dSt| ¡ƒdk�r¨| d¡dS||_td|jtd�| d¡dS)Nú503 Error: send HELO firstz ===> MAILrz 501 Syntax: MAIL FROM:
r¯zFROM:z503 Error: nested MAIL commandZBODYÚ7BIT)r³Z8BITMIMEz1501 Error: BODY can only be one of 7BIT, 8BITMIMEZSMTPUTF8FTz&501 Error: SMTPUTF8 takes no argumentsZSIZEz:552 Error: message size exceeds fixed maximum message sizerz:555 MAIL FROM parameters not recognized or not implementedzsender:r†)rErQrrPrFr¡r§rWr‰rŒr„r®r=Úpopr<rYÚisdigitr;Úintr}Úkeys)rr‘Ú syntaxerrr¥r«ZbodyÚsmtputf8Úsizer r rÚ smtp_MAILsh                    zSMTPChannel.smtp_MAILcCs|js| d¡dStd|td�|js6| d¡dSd}|jrH|d7}|dkr^| |¡dS| d|¡}| |¡\}}|sŠ| |¡dS|js¢|r¢| |¡dS| ¡  ¡|_ |  |j ¡}|dkrÒ| |¡dSt |  ¡ƒdkrð| d ¡dS|j |¡td |jtd�| d ¡dS) Nr²z ===> RCPTrz503 Error: need MAIL commandz501 Syntax: RCPT TO:
r¯zTO:rz8555 RCPT TO parameters not recognized or not implementedzrecips:r†)rErQrrPrWrFr¡r§r‰rŒr…r®r}r·rXr~)rr‘r¸r¥r«r r rÚ smtp_RCPT7s@           zSMTPChannel.smtp_RCPTcCs(|r| d¡dS| ¡| d¡dS)Nz501 Syntax: RSETr†)rQrDr—r r rÚ smtp_RSETZs  zSMTPChannel.smtp_RSETcCsZ|js| d¡dS|js(| d¡dS|r:| d¡dS|j|_| d¡| d¡dS)Nr²z503 Error: need RCPT commandz501 Syntax: DATAs . z#354 End data with .)rErQrXr|rVr[r—r r rÚ smtp_DATAas    zSMTPChannel.smtp_DATAcCs| d¡dS)Nz502 EXPN not implementedr�r—r r rÚ smtp_EXPNpszSMTPChannel.smtp_EXPN),rrrrUr|r+Ú collectionsÚ defaultdictr(Úpropertyr,ÚDATA_SIZE_DEFAULTr7r\rDZ_SMTPChannel__serverÚsetterZ_SMTPChannel__lineZ_SMTPChannel__stateZ_SMTPChannel__greetingZ_SMTPChannel__mailfromZ_SMTPChannel__rcpttosZ_SMTPChannel__dataZ_SMTPChannel__fqdnZ_SMTPChannel__peerZ_SMTPChannel__connZ_SMTPChannel__addrrQr‚r•r˜rœržrŸr¡r§r®r°r±r»r¼r½r¾r¿r r r rrws” ÿ '                       >   # 6#c@s2eZdZeZedddfdd„Zdd„Zdd„ZdS) rNFcCsÎ||_||_||_||_||_|r.|r.tdƒ‚tjj||d�zNt j |dt j iŽ}|  |dd|dd¡|  ¡| |¡| d¡Wn| ¡‚Yn(Xtd|jjt t ¡¡||ftd�dS) Nr/r-Útyperr$éz0%s started at %s Local addr: %s Remote addr:%sr)Z _localaddrÚ _remoteaddrr;r<r=r*ÚasyncoreÚ dispatcherr7rHZ getaddrinfoZ SOCK_STREAMZ create_socketZset_reuse_addrZbindZlistenrLrÚ __class__rÚtimeÚctimerP)rZ localaddrZ remoteaddrr;r.r<rSZ gai_resultsr r rr7xs6ÿ  þþzSMTPServer.__init__c Cs6tdt|ƒtd�| ||||j|j|j|j¡}dS)NzIncoming connection from %sr)rrOrPÚ channel_classr;Ú_mapr<r=)rr9r:Zchannelr r rÚhandle_accepted”súzSMTPServer.handle_acceptedcKst‚dS)aOverride this abstract method to handle messages from the client. peer is a tuple containing (ipaddr, port) of the client that made the socket connection to our smtp port. mailfrom is the raw address the client claims the message is coming from. rcpttos is a list of raw addresses the client wishes to deliver the message to. data is a string containing the entire full text of the message, headers (if supplied) and all. It has been `de-transparencied' according to RFC 821, Section 4.5.2. In other words, a line containing a `.' followed by other text has had the leading dot removed. kwargs is a dictionary containing additional information. It is empty if decode_data=True was given as init parameter, otherwise it will contain the following keys: 'mail_options': list of parameters to the mail command. All elements are uppercase strings. Example: ['BODY=8BITMIME', 'SMTPUTF8']. 'rcpt_options': same, for the rcpt command. This function should return None for a normal `250 Ok' response; otherwise, it should return the desired response string in RFC 821 format. N)ÚNotImplementedError©rrJrWrXr€r”r r rr�ŸszSMTPServer.process_message) rrrrrÍrÃr7rÏr�r r r rrtsþ  c@seZdZdd„Zdd„ZdS)rcCsld}| ¡}|D]V}|rL|sLd|d}t|tƒs@t| d¡ƒ}t|ƒd}t|tƒs^t|ƒ}t|ƒqdS)Nr$zX-Peer: rry)Ú splitlinesÚ isinstancerrOÚencoder)rrJr€Z inheadersÚlinesrŽZ peerheaderr r rÚ_print_message_contentÃs   z&DebuggingServer._print_message_contentcKsXtdƒ|r@| d¡r&td|dƒ| d¡r@td|dƒ| ||¡tdƒdS)Nz%---------- MESSAGE FOLLOWS ----------r„zmail options: %sr…zrcpt options: %s z%------------ END MESSAGE ------------)rÚgetrÖrÑr r rr�Ôs   zDebuggingServer.process_messageN)rrrrÖr�r r r rrÁscs,eZdZ‡fdd„Zdd„Zdd„Z‡ZS)rcs.d|kr|drtdƒ‚tt|ƒj||ŽdS)Nr<z$PureProxy does not support SMTPUTF8.©r*Úsuperrr7©rrMr”©rÊr rr7àszPureProxy.__init__c Csf| d¡}d}|D]}|sq(|d7}q| |d|d¡t |¡}| |||¡}td|td�dS)Nrrr$z X-Peer: %szwe got some refusals:r)rŒÚinsertrAr‡Ú_deliverrrP) rrJrWrXr€rÕr�rŽÚrefusedr r rr�ås   zPureProxy.process_messagec Csîddl}i}zB| ¡}| |jd|jd¡z| |||¡}W5| ¡XWnš|jk r„}ztdtd�|j }W5d}~XYnft |j fk rè}zBtd|j td�t |ddƒ}t |dd ƒ} |D]} || f|| <qÆW5d}~XYnX|S) Nrr$zgot SMTPRecipientsRefusedrZgotZ smtp_codeéÿÿÿÿZ smtp_errorÚignore)ÚsmtplibZSMTPZconnectrÇÚquitZsendmailZSMTPRecipientsRefusedrrPZ recipientsrKZ SMTPExceptionrÊr‹) rrWrXr€rárÞÚsÚeZerrcodeÚerrmsgÚrr r rrÝós$    zPureProxy._deliver)rrrr7r�rÝÚ __classcell__r r rÛrrßs cs$eZdZ‡fdd„Zdd„Z‡ZS)r cs.d|kr|drtdƒ‚tt|ƒj||ŽdS)Nr<z'MailmanProxy does not support SMTPUTF8.rØrÚrÛr rr7 szMailmanProxy.__init__cCs*ddlm}ddlm}ddlm}ddlm}g} |D]t} |  ¡ d¡d} |  d¡} t| ƒdkrfq8| d} t| ƒdkr„| d }nd }|  | ¡r8|d krœq8|   | | |f¡q8| D]\} } }|  | ¡q²t d d   |¡td�|rü| |||¡}t d|td�i}||ƒ}| |¡}| d¡�s&||d<| d¡�sDt t ¡¡|d<| D]Ü\} } }t d| td�| | ¡}|�s†|j| dd�}||| <|d k�r |j|d d�n‚|dk�rº|j|d d�nh|dk�rÔ|j|d d�nN|dk�rî|j|d d�n4|dk�rH|dk�r d|d <nd!|d <|j|d d��qHdS)"Nr)ÚStringIO)ÚUtils)ÚMessage)ÚMailListú@ú-r_r$r)rÚadminÚownerÚrequestr‡Úleavezforwarding recips:rƒrzwe got refusals:ÚfromZFromÚdateZDatezsending message to)Úlock)Útolistrî)Ztoadminrï)Ztoownerrð)Z torequest)r‡rñr‡Z subscribeZSubjectZ unsubscribe)ÚiorèZMailmanrérêrëÚlowerrŒr}Z list_existsr~Úremoverr‡rPrÝr×rËrÌZEnqueue)rrJrWrXr€rèrérêrëZ listnamesZrcptZlocalÚpartsZlistnamer�rÞZmlistsrãrZmlistr r rr�sb                    zMailmanProxy.process_message)rrrr7r�rçr r rÛrr s c@seZdZdZdZdZdZdS)ÚOptionsTrNF)rrrÚsetuidÚ classnameÚ size_limitr<r r r rrú_srúc Cspz.t tjdd…dddddddd g¡\}}Wn.tjk r\}ztd|ƒW5d}~XYnXtƒ}|D]º\}}|d kr‚td ƒqh|d kržttƒt d ¡qh|d kr®d|_ qh|dkr¾||_ qh|dkrÎtj a qh|dkrÞd|_ qh|dkrhzt|ƒ}||_Wqhtd|tj d�t d¡YqhXqht|ƒdk�rs„N þ  M-SB      þ